О программе BotikLook

BotikLook: система анализа сетевого трафика

O программе BotikLook

Программа BotikLook входит в состав пакета программ Botik Tools. Изначально программа разрабатывается для Абонентов Системы телекоммуникаций (СТ) "Ботик" студентами Университета города Переславля-Залесского и сотрудниками лаборатории телекоммуникаций "Ботик". Как бета-тестеры в развитии программы BotikLook участвуют и Абоненты СТ "Ботик".
Для работы в BotikLook необходимо зарегистрироваться на Персональном сайте Абонента системы Nadmin.

Цель разработки

Программа BotikLook разработана для того, чтобы обеспечить Абонентов СТ "Ботик" инструментом удобного просмотра детальной информации о своих сеансах связи, анализа своих расходов за использование услуг СТ "Ботик", выявления причин наибольших расходов. Программа BotikLook дополняет Персональный Сайт Абонента системы Nadmin — системы администрирования и управления региональной сетью.

Краткое описание принципов работы программы BotikLook

Работа программы BotikLook организована как пошаговый "мастер-помощник" (wizard). Четыре основных этапа работы программы:

  1. Авторизация на сервере. На этом этапе, так же, как и на Персональном Сайте Абонента, необходимо указать учётное имя абонента, имя пользователя и соответствующий пароль. Для доступа к данным пользователь должен иметь права ADMIN (про права ADMIN и USER — см. пояснения на Персональном Сайте Абонента).
  2. Синхронизация с сервером. На этом этапе выполняется сравнение данных, хранящихся в локальном хранилище статистики и данных из системы Nadmin. Состояние локального хранилища приводится в соответствие с данными в системе Nadmin.
  3. В диалоговом окне "Выбор статистики" пользователь определяет: за какой период времени, по каким услугам и какие виды статистики по данным услугам подлежат дальнейшему анализу. Соответствующие данные будут извлечены из локального хранилища и подвергнуты анализу.
  4. Далее выполняется этап просмотра и анализа выбранной статистики. В настоящее время имеется три средства просмотра и анализа (в дальнейшем предполагается увеличивать их число):
    • Просмотр расходов за трафик;
    • Просмотр источников расходов;
    • Просмотр гистограммы расходов;
    • Просмотр статистики по файлам.

Авторизация Синхронизация Выбор статистики Расходы за трафик Источники расходов Гистограмма расходов Таблица файлов Детальная статистика Настройка Четырехшаговый мастер-помощник (wizard)

Вспомогательное диалоговое окно "Настройка" используется для определения или изменения параметров программы BotikLook:

  • каталога для размещения локального хранилища статистики;
  • символов-разделителей, используемых для построения CSV-файлов (разделитель CSV-значений и символ десятичной точки);
  • уровень подробности таблицы источников расходов.

При первом запуске программы BotikLook вспомогательное диалоговое окно "Настройка" активируется принудительно. В дальнейшем открыть окно "Настройка" можно из большинства окон программы BotikLook при помощи соответствующей кнопки (см. Кнопки нижнего ряда).

Другим вспомогательным окном является окно просмотра детальной статистики.

Ссылки

  • Официальный сайт программы BotikLook: http://www.botik.ru/~botik/look/.
  • Загрузка актуальной версии пакета Botik Tools: http://www.botik.ru/~botik/tools/download.ru.html.


Основные понятия и термины

Локальное хранилище статистики
Каталог, содержащий базы данных Абонента, в которых хранится сырая статистика, а также результаты её анализа — максимально подробные данные об оказанных Абоненту услугах связи. Пользователь сам определяет (в диалоговом окне "Настройка") на каком диске и в каком каталоге будет организовано локальное хранилище статистики. При необходимости пользователь сам обеспечивает меры по защите от несанкционированного доступа к локальному хранилищу статистики.
CSV
Comma-Separated Values, "значения, разделённые запятыми", формат хранения данных (часто таблиц), в котором данные (например, значения в ячейках таблиц) перечисляются через запятую или другой символ-разделитель элементов списка.
Все таблицы и гистограммы BotikLook можно экспортировать в CSV-файлы.
Установленные по умолчанию в окне "Настройки" значения параметров "разделитель CSV-значений" и "десятичная точка" уже соответствуют следующим системным установкам Windows (пример для Windows XP):

Control Panel :: Regional and Language Options :: Regional Options :: Customize :: Numbers :: (List separator и Decimal symbol).

Только в случае этого соответствия CSV-файлы, экспортированные из BotikLook, будут успешно загружаться в программу Microsoft Office Excel.


Окно настроек

Настройка

В окне настроек можно задать следующие параметры:

  • Домашний каталог — определяет на каком диске и в каком каталоге будет организовано локальное хранилище статистики. Изменение домашнего каталога возможно только на этапе авторизации или при первом запуске BotikLook.
  • Запрашивать подтверждение на отправку — определяет нужно ли запрашивать подтверждение отправки разработчикам отчётов об ошибках в программе
  • Крупная организация — опция, которую рекомендуется выбирать перед синхронизацией с крупной организацией (более 10 подключений). Эта опция существенно снижает расход оперативной памяти, но увеличивает нагрузку на жёсткий диск. Как следствие, программа будет работать медленнее, но переполнения памяти не произойдёт (в частности, на этапе анализа данных). По умолчанию опция отключена.
  • Быстрый анализ — включение этой опции позволяет при синхронизации сильно сократить время и ресурсы, нужные для этого процесса. Но при этом в таблице расходов будет менее детальная информация о причинах расходов. Например, не будет информации о стоимости входящего и исходящего трафика по отдельности. По умолчанию опция включена.
  • Разделитель CSV-значений — символ, которым будут разделяться значения ячеек таблиц при экспорте таблиц в файлы формата CSV. Возможные варианты выбора: ";" и ",".
  • Десятичная точка — символ, отделяющий целую часть числа от дробной — в BotikLook используется только при экспорте таблиц в файлы формата CSV. Возможные варианты выбора: "." и ",".
Первую и вторую опции можно комбинировать для достижения той или иной цели. Если нужно осуществить быструю синхронизацию с какой-либо организацией, то 1-ю опцию можно отключить, а 2-ю включить. Но если нужно провести как можно более подробный анализ статистики, то 2-ю опцию нужно выключить. Если при этом возникают проблемы нехватки ресурсов, то можно попробовать включить 1-ю опцию. Однако, при этом анализ может занять довольно продолжительное время.

После установки желательных значений у параметров следует использовать одну из кнопок:

  • Применение настроек — настройки применяются в текущем сеансе работы программы BotikLook;
  • Применение и сохранение настроек — настройки применяются в текущем сеансе работы и сохраняются для использования при последующих запусках программы BotikLook.

При первом запуске программы BotikLook окно "Настройка" открывается автоматически. В этом случае, после настройки и сохранения параметров, нажатие на кнопку перехода Далее инициирует этап авторизации.

Замечания

1. Для того, чтобы CSV-файлы успешно загружались в программу Microsoft Office Excel необходимо, чтобы значения параметров "разделитель CSV-значений" и "десятичная точка" соответствовали бы следующим системным установкам (показано для Microsoft Windows XP Eng):

Control Panel :: Regional and Language Options :: Regional Options :: Customize :: Numbers :: (List separator и Decimal symbol).

Значения, заданные по умолчанию программой BotikLook, уже соответствуют данным системным установкам.

2. Из большинства окон программы BotikLook можно открыть окно "Настройки" при нажатии на кнопку Вызов окна настроек в нижнем ряду кнопок.

См. также

  • Кнопки нижнего ряда
  • Основные понятия и термины::CSV
  • О программе BotikLook


Окно авторизации

Авторизация

На этапе авторизации пользователь вводит свои учётные данные: учётное имя абонента (название своей организации), имя пользователя и пароль — точно так же, как на Персональном Сайте Абонента. К работе в BotikLook допускаются только пользователи, имеющие права администратора (ADMIN) — см. пояснения на Персональном Сайте Абонента.

(Администраторы-сотрудники лаборатории "Ботик" имеют права доступа ADMIN к данным любого Абонента с любым учётным именем)

В большинстве случаев поле "Учетное имя абонента" должно правильно заполняться программой BotikLook автоматически. Если этого не произошло, пользователь должен заполнить его самостоятельно.

В поля авторизации следует занести учётные данные пользователя с правами ADMIN. Тогда после нажатия на кнопку перехода [image] начинается этап синхронизации — выполняется сравнение данных, хранящихся в локальном хранилище статистики, с данными в системе Nadmin, состояние локального хранилища приводится в соответствие с данными в системе Nadmin.

Кнопка "Выбрать период" открывает диалоговое окно, в котором можно выбрать интересующий период времени. Это позволяет не закачивать сразу всю статистику из системы Nadmin, а скачать только статистику за указанный период времени. Это существенно упрощает работу с крупными организациями.

Выбор периода времени

Администраторы-сотрудники лаборатории "Ботик" имеют права доступа ADMIN к статистике любого Абонента, с любым учётным именем. При авторизации сотрудника СТ "Ботик" возникает специальное диалоговое окно, в котором он может указать название интересующей его организации.

Окно ввода целевой организации

См. также

  • О программе BotikLook
  • Кнопки нижнего ряда


Окно автономной работы

Автономный режим

В BotikLook имеется возможность работы в автономном режиме — в этом случае синхронизация не выполняется. Для просмотра и анализа используется статистика (Осторожно! Возможно она неактуальная!), ранее загруженная в локальное хранилище.

Работа в автономном режиме

См. также

  • О программе BotikLook


Синхронизация с сервером

Синхронизация

На этапе синхронизации происходит сравнение данных из локального хранилища статистики и данных из системы Nadmin. Состояние локального хранилища приводится в соответствие с данными в системе Nadmin.

После синхронизации начинается этап выбора статистики.

Замечание: для крупных организаций и при редком использовании программы BotikLook возможны значительные различия между состоянием локального хранилища и данными в системе Nadmin. В этом случае синхронизация может занимать несколько часов. Частое использование программы BotikLook сокращает время синхронизации (даже для крупных организаций).

См. также

  • О программе BotikLook


Выбор статистики

На этапе выбора статистики пользователь выбирает интересующие его:

  • услуги его организации;
  • виды статистики по данным услугам;
  • период времени.

В диалоговом окне выбора статистики отображается таблица, в которой строки соответствуют услугам организации, а столбцы — видам статистики.

Окно выбора статистики

Над каждым столбцом есть группа из трёх кнопок:

  • Убрать всё — снимает всё выделение в столбце;
  • Реверс — меняет всё выделение на обратное;
  • Выбрать всё — выделяет весь столбец.

Кнопки перехода

  • Назад — возвращает пользователя на этап авторизации;
  • Далее — переход на этап, выбранный в меню в нижнем ряду кнопок (по умолчанию это таблица трафика).

См. также

  • Кнопки нижнего ряда


Расходы за трафик

В таблице "Расходы за трафик" представлены расходы организации за сетевой трафик. Строки таблицы соответствуют выбранным на предыдущем этапе услугам, столбцы соответствуют выбранным видам трафика.

Окно расходов за трафик

В меню под таблицей можно выбрать один из двух режимов её отображения:

  • Денежный, при котором отображается стоимость трафика (в рублях);
  • Натуральный, при котором отображается объём трафика в натуральных единицах (байты, минуты и др.).

Операции с клетками таблицы

Двойной щелчок левой нопкой или одинарный щелчок правой кнопкой мыши на ячейке таблицы открывает окно детальной статистики, соответствующее выбранной ячейке.

Можно выделить ячейку одинарным щелчком мыши и скопировать текст из ячейки в буфер обмена стандартным сочетанием клавиш Windows "Ctrl+Insert" или "Ctrl+c".

Кнопки

  • Назад — возврат на этап выбора статистики;
  • Далее — переход на этап, указанный в меню рядом (обычно это анализ расходов).

См. также

  • Кнопки нижнего ряда
  • Основные понятия и термины::CSV


Окно источников расходов

Анализ источников расходов

Таблица "Анализ источников расходов" предоставляет информацию о главных источниках расходов организации за сетевой трафик. В таблице есть следующие колонки:

  • Ключ — это счётчик, источник расходов, вид (категория) расходов; счётчики могут быть:
    • независимыми — например, "[x1.botik.ru]" или "IP-трафик";
    • связанными — например, "[x1.botik.ru] IP-трафик" или "[x1.botik.ru] Сайт www.site.org" — вторая категория является частным случаем первой, здесь у нас вложенные категории.
  • Стоимость — объём расходов по данной категории;
  • Натуральная — натуральное значение счётчика (байты, минуты и т.п.)
  • Доля в % — доля расходов на счётчик по отношению к расходам на первую категорию в таблице. Минимально допустимое значение в этой колонке задаётся в настройках изменением значения поля "Уровень подробности".

Таблица источников расходов

Операции с клетками таблицы

Можно выделить ячейку одинарным щелчком мыши и скопировать текст из ячейки в буфер обмена стандартным сочетанием клавиш Windows "Ctrl+Insert" или "Ctrl+c".

Двойной щелчок левой нопкой или одинарный щелчок правой кнопкой мыши на ячейке таблицы открывает окно детальной статистики, соответствующее выбранной ячейке (выбранной категории).

Кнопки

  • Пред. страница След. страница — переход на предыдущую и следующую страницы таблицы;
  • Назад — возврат на этап выбора статистики;
  • Далее — переход на этап, указанный в меню рядом (обычно это гистограмма расходов).

См. также

  • Кнопки нижнего ряда
  • Основные понятия и термины::CSV


Гистограмма расходов

Гистограмма расходов позволяет визуально оценить уровень расходов абонента СТ "Ботик" на сетевой трафик по выбранным услугам, категориям трафика и периоду времени:

Гистограмма представляет собой набор столбцов, каждый из которых либо соответствует отдельному периоду времени (например, квартал), либо входит в группу столбцов, представляющих собой разбиение этого периода (например, по 3 месяца):

Возможны разбиения гистограммы по годам, кварталам, месяцам, неделям, дням, полудням и часам. Этим управляет меню вида Меню вида гистограммы, расположенное в правой части окна на приборной панели над кнопкой "Подробнее". Нажатие на кнопку Подробнее приведёт к разбиению каждого столбца на группу столбцов. Нажатие на кнопку Сжато произведёт обратный эффект.

Максимально возможный уровень подробности – "По часам-Подробнее" – позволяет построить гистограмму, в которой каждый столбец соответствует расходам за 5 минут. Следует учесть, что немедленный переход на этот уровень может привести к задержкам при построении гистограммы, поскольку при выборе большого периода времени количество столбцов на максимально возможном уровне подробности может составлять несколько тысяч.

Каждый столбец может быть раскрашен несколькими цветами. Каждый цвет представляет отдельную категорию трафика. При наведении курсором на цветную область столбца отображается название соответствующей категории трафика и натуральное или денежное значение, в зависимости от выбранного режима:

Режим отображения гистограммы (Денежный или Натуральный) выбирается с помощью меню, расположенного под гистограммой.

Выбрать отображаемые виды трафика можно на приборной панели:

Выбор видов трафика

Щелчок левой кнопкой мыши на столбце позволяет построить гистограмму специально для того периода времени, который соответствует выбранному столбцу. Таким образом, эта возможность позволяет сократить анализируемый период времени, что облегчает изучение гистограммы и уменьшает нагрузку на вычислительные ресурсы компьютера. На максимальном уровне подробности – "По часам-Подробнее" – эта функция не работает.

Также возможно выделение мышью нескольких столбцов с той же целью уменьшения анализируемого периода времени. Эта процедура выполняется аналогично выделению мышью значков на Рабочем столе Windows. На максимальном уровне подробности – "По часам-Подробнее" – эта функция также не работает. Последующее построение гистограммы для выбранного периода осуществляется нажатием кнопки "Подробнее":

Щелчок правой кнопкой мыши на столбце отображает таблицу детальной статистики для периода времени, обозначаемого этим столбцом.

Кнопки

  • Предыдущее состояние гистограммы Следующее состояние гистограммы — переход на предыдущий и следующий шаги в истории работы с гистограммой. История сохраняет любые действия пользователя в окне гистограммы. Например, изменение режима отображения или уменьшение периода времени.
  • Экспорт в Excel — экспорт гистограммы в Excel (.xls) либо CSV-файл;
  • Назад — возврат на этап выбора статистики;
  • Далее — переход на этап, указанный в меню рядом (обычно это таблица файлов).

См. также

  • Кнопки нижнего ряда
  • Основные понятия и термины::CSV


Таблица файлов

"Таблица файлов" предоставляет информацию о файлах, загруженных организацией по протоколам HTTP или HTTPS при условии использования proxy-сервера. В таблице есть следующие колонки:

  • Дата — дата загрузки файла с точностью до дня;
  • Адрес — адрес компьютера в сети, на который был скачан файл;
  • Файл — ссылка на скачанный файл. Левый щелчок мыши открывает системный браузер для данной ссылки, правый позволяет скопировать ссылку в буфер обмена;
  • Стоимость — стоимость скачанного файла;
  • Размер — размер скачанного файла;

Таблица отсортирована по колонке "Стоимость".

Операции с клетками таблицы

Можно выделить ячейку одинарным щелчком мыши (кроме ячеек из колонки "Файл" – см. выше) и скопировать текст из ячейки в буфер обмена стандартным сочетанием клавиш Windows "Ctrl+Insert" или "Ctrl+c".

Кнопки

  • Назад — возврат на этап выбора статистики;
  • Далее — переход на этап, указанный в меню рядом (обычно это таблица трафика).

См. также

  • Кнопки нижнего ряда
  • Основные понятия и термины::CSV


Окно детальной статистики

В окне детальной статистики содержимое файлов статистики, загруженных с сервера на этапе Синхронизации, отображается в виде таблицы. Эта таблица предоставляет наиболее полную и достоверную информацию обо всей сетевой активности организации.

Таблица детальной статистики

В таблице может быть отображено не более 200 записей. Следующий набор записей можно отобразить, нажав на кнопку Следующая страница.
Каждая запись соответствует отдельной сетевой транзакции (обмену). В таблице детальной статистики отображаются обмены, стоимость которых не меньше 1 копейки.
Также бывают записи, содержащие суммарную информацию о множестве малых обменов IP-трафиком, произошедших в указанное время. Такие обмены происходят один за другим, как правило, за короткий промежуток времени. Их стоимость и объём в байтах суммируются, а сетевые адреса и порты объединяются в группы, элементы которых разделяются двоеточием. Каждая группа содержит не более 10 элементов.

Таблицу можно отсортировать (как по возрастанию, так и по убыванию) по любой из её колонок. Для этого нужно щёлкнуть мышью по названию колонки.

В столбце "Дата" содержится информация о точном времени окончания пересылки данных (обмена).

Операции с клетками таблицы

Двойной щелчок мышью на ячейке с IP-адресом в колонке "Удал. адрес" преобразует IP-адрес в доменное имя.

Можно выделить ячейку одинарным щелчком мыши и скопировать текст из ячейки в буфер обмена стандартным сочетанием клавиш Windows "Ctrl+Insert" или "Ctrl+c".

Кнопки

  • Пред. страница След. страница — переход на предыдущую и следующую страницы таблицы;

См. также

  • Кнопки нижнего ряда


Служба BotikLook

Служба BotikLook позволяет осуществлять синхронизацию по расписанию и независимо от того, какой пользователь работает в системе.

Для работы службы необходимо:

  1. Выполнить настройку программы BotikLook (см. раздел Настройка).
  2. Запустить менеджер службы BotikLook через меню "Старт" —> "BotikTools" —> "BotikLook Service Manager".
Сразу после запуска менеджера в системной области оповещений (tray) появляется значок службы. Левый клик по иконке вызывает окно конфигурации службы, а правый клик открывает контекстное меню менеджера.

Окно конфигурации службы

Окно конфигурации службы

В окне конфигурации можно указать:

  • учётные данные пользователей системы Nadmin. Каждую из добавленных учётных записей (имя абонента, имя пользователя и пароль) можно затем изменить, удалить или поменять её приоритет (перемещением вверх или вниз), выбрав её переключателем в разделе "Очередь заданий" и нажав на соответствующую кнопку справа;
  • в разделе "Расписание" можно указать периодичность и время начала синхронизации. Возможны три варианта расписания:
    1. "Часы": синхронизация будет происходить каждый указанный час; первая произойдёт ровно через указанное количество часов после сохранения настроек;

      Расписание по часам

    2. "Дни": синхронизация будет происходить каждый указанный день в назначенное время;

      Расписание по дням

    3. "Недели": синхронизация будет происходить каждую указанную неделю в указанные дни и в назначенное время;

      Расписание по неделям

    4. При желании можно отключить синхронизацию, убрав галочку напротив названия раздела "Расписание".

  • в разделе "Файл с настройками" можно выбрать место хранения и название файла, в котором будут сохранены все настройки службы. В том числе будут сохранены учётные данные пользователей, поэтому рекомендуется сохранять файл с настройками в надёжном месте, например, на съемном диске (дискета или Flash/USB-диск).
Выбор опции "Автостарт службы при старте системы" даёт возможность запускать службу автоматически при старте Windows.

После нажатия на кнопку "OK" или "Применить" настройки сохраняются в указанном месте для последующего использования службой. Они вступают в силу только после старта или рестарта службы через меню управления службой.

Меню управления службой

Правый клик по иконке открывает контекстное меню менеджера. Оно позволяет управлять службой.

Меню управления службой (служба не запущена) Меню управления службой (служба работает) Меню управления службой (служба приостановлена)

В этом меню могут быть следующие пункты:

  • "Старт": эта команда запускает службу. После запуска служба ждёт наступления момента начала синхронизации, указанного в расписании. Когда он наступит, начнётся синхронизация для всех указанных учётных записей по порядку (сверху-вниз).
  • "Стоп": эта команда останавливает службу.
  • "Пауза": этот пункт даёт возможность приостановить работы службы. Поскольку BotikLook для своей работы требует достаточно много процессорных ресурсов, пауза помогает освободить их на время для выполнения важных пользовательских задач другими приложениями.
  • "Возобновить": возобновляет работу службы после паузы.
  • "Рестарт": последовательно выполняет остановку и запуск службы.
  • "Синхронизироваться": эта команда позволяет выполнить синхронизацию, не дожидаясь наступления времени, указанного в расписании. Если служба уже выполняет синхронизацию, то данная команда будет проигнорирована.
  • "Настройки": открывает окно конфигурации.
  • "Справка": открывает эту страницу справки. Может не сработать, если не открыто окно конфигурации.
  • "Выход": завершает работу менеджера.
Примечание: если служба BotikLook выполняет задания, то появление контекстного меню при правом щелчке мышью на иконке службы может происходить с некоторой (иногда значительной) задержкой. Пожалуйста, будьте терпеливы.


Кнопки нижнего ряда

  • Далее — переход на следующий этап
  • Назад — переход на предыдущий этап
  • Помощь — вызов справки для текущего окна
  • Настройка — вызов окна настроек программы
  • Применить и сохранить — применение и сохранение настроек
  • Применить — применение настроек
  • Закрыть — закрытие текущего окна
  • Экспорт в Excel — экспорт текущей таблицы в формат Excel (.xls) либо в CSV; экспорт в Excel возможен только в ОС Windows с установленным пакетом программ Microsoft Office.
  • Выход — выход из программы

См. также

  • Основные понятия и термины::CSV