О программе BotikMap

BotikMap: специализированная векторная карта СТ "Ботик"

O программе BotikMap

Программа BotikMap входит в состав пакета программ Botik Tools. Программа разрабатывается для Абонентов СТ "Ботик" группой технической поддержки СТ "Ботик". В её развитии могут участвовать абоненты СТ "Ботик" (и как разработчики, и как бета-тестеры).

Официальный сайт программы: http://www.botik.ru/~botik/map/.

Цель разработки: дать возможность абонентам СТ "Ботик" на специализированной векторной карте Переславля-Залесского в реальном масштабе времени видеть состояние СТ "Ботик": в каких домах города проложена магистраль, какие участки сети функционируют, а где — неисправности. Предусмотрено наполнение карты гео-объектами, справочной информацией, реализован поиск улиц, домов, организаций и многое другое.


Общие сведения о программе BotikMap

Программа BotikMap позволяет просматривать и редактировать объекты геоинформационной системы г. Переславля-Залесского.

Главное окно программы BotikMap

После запуска программы пользователю будет предложено ввести свои учётные данные для загрузки гео-объектов. Это те данные, которые используются для входа в Надмин::Абоненту. После успешной авторизации сервер пересылает пользователю объекты геоинформационной системы города.

Все объекты подразделены на категории, которые называются слоями. К числу слоёв относятся: "Оборудование", "Каналы", "Объекты", "Дома", "Улицы", "Зелень", "Мосты", "Водоёмы" и "Кварталы".

Для каждого слоя определены свои подкатегории объектов, которые допустимы в этом слое. Например, слою "Водоёмы" соответствуют подкатегории: "Oзеро", "Название Водоёма", "Pека", "Pучей". Набор объектов, доступных пользователю, зависит от выбранного слоя. В программе BotikMap есть возможность переключения на тот или иной слой и создания различных объектов в этом слое.


Основные понятия BotikMap

ГИС (ГеоИнформационная Система) — информационная система, обеспечивающая сбор, хранение, обработку, доступ, отображение и распространение географических данных. ГИС предназначена для решения научных и прикладных задач инвентаризации, анализа, оценки, прогноза и управления окружающей средой и территориальной организацией общества. Основу ГИС составляют автоматизированные картографические системы, а главными источниками информации служат различные геоизображения.

Геоизображение — пространственно-временная масштабная генерализованная модель земных (планетных) объектов или процессов, представленная в графической образной форме. Различают:

  • двумерные (плоские) геоизображения: карты, планы, электронные карты, аэро- и космические снимки;
  • трехмерные (объемные) геоизображения: анаглифы, картографические голограммы и т.д.

Слой — совокупность однотипных пространственных объектов, относящихся к одной теме или классу объектов в пределах некоторой территории и в системе координат, общих для набора слоёв.

Объект — цифровое представление объекта реальности (цифровая модель местности), содержащее его местоуказание и набор свойств, характеристик, атрибутов или сам этот объект. В BotikMap выделяются четыре основных типа объектов:

  • точечные;
  • линейные;
  • площадные (полигональные);
  • текстовые.


Панели инструментов BotikMap

В BotikMap есть две панели инструментов — сверху и слева.
Кнопки на верхней панели инструментов используются для выполнения следующих функций:
  • Чтение из файла: позволяет загрузить объекты ГИС из файла, который должен иметь формат .gis или .txt
  • Сохранение в файл: сохранение всех изменений в файл с расширением ".gis" или ".txt". При этом всё его старое содержимое стирается и он записывается заново.
  • Вызов справки о программе.
  • Менеджер слоёв. В нём можно выбрать текущий (рабочий) слой, изменить видимость (видимый/невидимый), и редактируемость (редактируемый/нередактируемый) слоёв. С помощью кнопок "Выбрать всё" и "Убрать всё" в окне менеджера можно изменить видимость и редактируемость сразу всех слоёв.

    Менеджер слоёв программы BotikMap

  • Поиск: позволяет по заданным критериям искать объекты на карте. В качестве критериев для поиска можно указать слои, подкатегории объектов, типы, состояния, а также фрагменты имени, адреса или комментария. Набор доступных объектов зависит от выбранных слоёв, и набор доступных типов и состояний — от выбранных объектов. Имеется 2 варианта поиска: обычный (кнопка "Найти") и радиусный (кнопка "Найти ближайшие к точке"). Если выбран 2-й вариант, то нужно будет указать точку карты, вблизи которой нужно найти объекты. Найденные объекты в этом случае будут отсортированы по возрастанию в порядке их дальности от выбранной точки. Как в первом, так и во втором режиме поиска, в результате отображается список найденных объектов. Каждый найденный объект в этом списке представляет собой гиперссылку. После нажатия левой кнопкой мыши на каком-либо объекте, окно просмотра карты перемещается в область выбранного объекта.

    Окно поиска программы BotikMap

  • Выбор масштаба: эта кнопка-меню позволяет непосредственно выбрать масштаб и является альтернативой инструменту "Изменение масштаба" на левой панели инструментов (о нём ниже).
  • Выбор слоя: эта кнопка-меню позволяет выбрать верхний (рабочий) слой, не используя при этом Менеджер слоёв.
  • Авторизация на сервере. Здесь нужно указать учётные данные: учётное имя абонента (название организации), имя пользователя и пароль — точно так же, как на Персональном Сайте Абонента. Сразу после успешной авторизации начинается загрузка карты города.
    Авторизация на сервере
  • Отправка созданных или измененных объектов на сервер. Программа вычисляет какие из объектов были созданы, модифицированы или удалены с карты и позволяет выполнить с ними различные действия: записать на сервер, удалить в редакторе, удалить на сервере или восстановить с сервера.
  • Отображение миникарты (обзорной карты), которая представляет собой уменьшенную копию основной карты и позволяет легко перемещаться по основной карте щелчками мыши по миникарте. Нажатие кнопок "+" и "-" приводит, соответственно, к увеличению и уменьшению размеров миникарты.

  • Делает снимок экрана.
  • Отображение или скрытие альтернативной карты Переславля. Тип карты (спутниковая или схематическая) можно выбрать через селектор "Карты местности". Для перемещения такой карты вверх-вниз-влево-вправо можно использовать сочетания клавиш Ctrl+Alt+Up/Down/Left/Right. Это может понадобиться для приведения в соответствие векторных объектов карты BotikMap и объектов на альтернативной (напр. спутниковой) карте.
Кнопки левой панели инструментов позволяют создавать или редактировать объекты BotikMap:
  • Выбор объекта: позволяет выделить один или несколько объектов. Выделение осуществляется несколькими способами:
    1. Щелчком на объекте левой кнопкой мыши (выделяется только один объект).
    2. Удержанием клавиши "Ctrl" и щелчками левой кнопкой мыши на объектах (каждый объект добавляется к группе ранее выбранных объектов или удаляется из неё).
    3. удержанием левой клавиши мыши на свободном месте карты (начальное положение) и перемещением указателя мыши — появится пунктирный прямоугольник, охватывающий экран от начального положения до текущего положения мыши; выделенными становятся только те объекты, которые пересекаются с данным прямоугольником или касаются его.
    В выделенном состоянии у объекта видны его узлы, которые можно передвигать, удалять или добавлять новые. Сам объект можно перемещать как с помощью указателя мыши, так и с помощью клавиш со стрелками (перемещение с небольшим фиксированным шагом), а также их комбинацией с клавишей "Ctrl" (перемещение с более крупным фиксированным шагом). Нажатие правой кнопкой мыши на объекте открывает окно его свойств, где можно изменить его тип, состояние, имя, адрес или комментарий.
  • Изменение масштаба: этот инструмент меняет масштаб просмотра карты (зум). Щелчёк левой кнопкой в каком-либо месте карты делает увеличение, а правой — уменьшение масштаба относительно выбранной точки (она становится центральной точкой экрана). Всего существует 7 уровней масштабирования: 1-й самый мелкий, 7-й — самый крупный. Выбрать масштаб можно также с помощью меню "Выбор масштаба" на верхней панели инструментов.
  • Инструмент "рука" для перемещения по карте. Нажатие и удержание левой кнопки мыши "захватывает" карту, движение мышью перемещает карту в нужном направлении, а отпускание левой кнопки мыши "отпускает" и карту.
  • Добавление/Удаление узлов: позволяет добавлять новые или удалять старые узлы у площадных или линейных объектов. Чтобы создать узел на выбранном ребре, нужно щёлкнуть левой клавишей мыши на начальном узле этого ребра. При этом новый узел создаётся ровно посередине между начальным и конечным узлами выбранного ребра. Для удаления узла нужно щёлкнуть на нём правой клавишей мыши.
  • Изменение сглаживания: этот инструмент позволяет включить или отключить сглаживание углов у линейных или площадных объектов. Сглаживание осуществляется при помощи кривых Безье.
Все остальные кнопки на левой панели инструментов отвечают за создание объектов ГИС. Состав этих кнопок определяется тем, какой слой выбран в качестве текущего.

Сочетания клавиш

  • Ctrl+R: вращение выделенных объектов по часовой стрелке.
  • Ctrl+Alt+R: вращение выделенных объектов против часовой стрелки.
  • Ctrl+C: копирование выделенных объектов.
  • Ctrl+Insert: копирование выделенных объектов.
  • Ctrl+V: Вставка копий объектов на карту.
  • Shift+Insert: Вставка копий объектов на карту.
  • Ctrl+A: Выделение всех объектов на видимой части карты.
  • Стрелки Up/Down/Left/Right: перемещение выделенных объектов по карте.
  • Ctrl+Up/Down/Left/Right: более быстрое перемещение выделенных объектов по карте.
  • Ctrl+O: Прочитать объекты из файла.
  • Ctrl+S: Сохранить объекты в файл.
  • Ctrl+F: Отобразить окно поиска.
  • Ctrl+X: Увеличить масштаб карты (zoom in); также, можно использовать колесо прокрутки.
  • Ctrl+Z: Уменьшить масштаб карты (zoom out); также, можно использовать колесо прокрутки.
  • Ctrl+Q: Выход из программы.
  • Ctrl+M: Сменить сглаживание углов у выделенных объектов.
  • Ctrl+W: Связать точечный объект (напр. узел сети) с другим объектом (напр. домом).
  • Ctrl+Shift+Right: Сдвиг подложки (альтерн. карты) вправо.
  • Ctrl+Shift+Left: Сдвиг подложки (альтерн. карты) влево.
  • Ctrl+Shift+Up: Сдвиг подложки (альтерн. карты) вверх.
  • Ctrl+Shift+Down: Сдвиг подложки (альтерн. карты) вниз.


Создание объектов в BotikMap

Все гео-объекты можно разделить по способу их создания на следующие классы:
  • линейные;
  • площадные;
  • текстовые;
  • точечные;
  • текстово-линейные;
  • линейно-площадные.
Рассмотрим более подробно способы создания объектов каждого класса.
  1. Линейным объектом может быть как обычная ломаная, так и сглаженная линия. Такие объекты рисуются следующим образом: щелчёк левой кнопкой мыши добавляет узел у линии, щелчёк правой кнопкой также добавляет узел и завершает процесс создания объекта. Количество узлов может быть произвольным. Примеры объектов этого класса: канал связи, бордюр, ручей.
  2. Площадной объект — это по сути замкнутая ломаная линия с заливкой. Рёбрами этого объекта могут быть как прямые, так и сглаженные линии. Создание площадных объектов происходит так же, как и линейных. Отличие лишь в том, что рисуется не линия, а замкнутый многоугольник. Примеры объектов этого класса: дом, квартал, вал, лес, кустарник, озеро, река.
  3. Текстовые объекты являются обычным горизонтальным текстом, которые рисуются следующим образом: сначала левым щелчком мыши выбирается точка привязки текста, затем в появившемся окне вводится сам текст и указывается его расположение относительно точки привязки: сверху, снизу, справа, слева, по центру и т.д. После нажатия клавиши "Enter" или кнопки "ОК" в выбранной точке с заданным расположением создаётся введённый текст. Примеры объектов этого класса: номер дома, название квартала.
  4. Точечные объекты рисуются одним левым щелчком мыши. Пример объекта этого класса: ящик с телекоммуникационным оборудованием.
  5. Текстово-линейные объекты состоят из текста, нанесённого на опорную ломаную. Ломаная рисуется так же, как и обычная линия, но по окончании её создания нужно будет ввести текст. При нажатии на клавишу "Enter" или кнопку "ОК" этот текст будет расположен вдоль ломаной. Примеры объектов этого класса: название улицы и название водоёма.
  6. Линейно-площадные объекты — это объекты, состоящие из многоугольников и линий. К таким объектам относится объект "Мост". Он рисуется путём выбора восьми точек (a b c d e f g h), которые определяют:
    • четырёхугольник ("b c f g"),
    • две линии ("a b c d" и "e f g h").
Схема рисования объекта 'Мост'