Что такое Botik::Key Pro?

Botik::Key Pro -- это клиентская часть для системы BotikKey. Она может использоваться вместо клиента, написанного на Tcl/Tk разработчиками CT "Ботик" (далее BotikKey Lite (это название было предложено разработчиками этой версии программы, на общей встрече проведенной 24-08-2004)) и поставляемого в пакете программ BotikTools. Botik::Key Pro разработана специально для семейства операционных систем MS Windows.

Botik::Key Pro является совершенно бесплатной программой (freeware). Она не содержит никакого мусора вроде рекламных банеров (adware), шпионского кода (spyware) и прочей нечисти (malware). Честное слово! Я делаю это только для забавы (just for fun) и обучения, а не за деньги.

Но если Вам понравилась эта программа, и хотите чтобы она развивалась, и за это Вы решите меня как-нибудь отблагодарить, то я не буду долго сопротивляться. ;-)

См. также:
Что нового в этой версии?
Зачем нужен другой клиент?
Подробнее о Botik::Key Pro

Версия: Дата обновления:


Зачем нужен другой клиент?

BotikKey Lite является обычным приложением операционной системы и стартует в момент входа пользователя в систему, а при выходе пользователя из системы, программа прекращает выполняться, как и любая другая пользовательская задача. Из-за подобного поведения возникает ряд неудобств на операционных системах MS Windows NT/2000/XP/2003:

  • у компьютера нет доступа к сети, если пользователь не зарегистрировался в системе. Таким образом, если у Вас на машине запущены такие сервисы как Web-сервер, Ftp-сервер, средства удаленного администрирования (R-Admin, Terminal Services и проч.), средства совместного использования ресурсов компьютера (накопителей, принтеров) и прочие сетевые сервисы, все они будут недоступны;
  • из-за позднего старта программы, операционная система при проверке доступа к автоматически подключаемым сетевым дискам начинает "ругаться", так как в данный момент еще не запущена программа, и сеть остается недоступна.


Подробнее о Botik::Key Pro

Botik::Key Pro -- это пакет программ написанный на языке С (и немного C++ ;-) с использованием Win32 API специально для операционных систем MS Windows 9x/ME/NT/2000/XP/2003 и представляет собой клиент-серверную архитектуру.

В пакете содержатся следующие модули:

  • bkpsvc32.exe -- серверная часть. Это сервис операционной системы MS Windows NT/2000/XP/2003, запускающийся автоматически во время загрузки операционной системы (до того как пользователь зарегистрируется в системе). В сервисе реализован клиент BotikKey. Сервис стартует с определенными пользователем настройками.
  • bkpmgr32.exe -- клиентская часть. Это менеджер управления и конфигурации сервиса. Позволяет задавать так называемые startup настройки сервиса (начальный уровень доступа к сети, ключ доступа, параметры подключения к серверу BotikKey и прочее) и управлять интерактивно доступом к сети при помощи переключателя. Так же настраивается установка требуемого доступа к сети во время запуска и выключения менеджера.
  • pw2key32.exe -- программа для построения ключей доступа на основании введенной парольной фразы. Аналогом является программа Pswd2Key из пакета BotikTools.

Таким образом, имея в составе системную сервисную программу, Botik::Key Pro позволяет операционной системе работать с сетью вне зависимости от того зарегистрирован ли в данный момент пользователь или нет.

Дополнительный сервис: автоматический контроль за выходом в свет новых версий программы Botik::Key Pro

С периодичностью программа Botik::Key Pro опрашивает некий HTTP-файл, в котором содержится номер текущей версии Botik::Key Pro. Если у пользователя установлена устаревшая версия, ему будет сообщено, что на сайте доступна новая версия.

Работа программы в операционных системах Windows NT/2000/XP/2003

Современные Microsoft Windows (например, MS Windows 2000/XP/2003) позволяют одновременно работать нескольким пользователям за счет удаленного Desctop'а или в качестве SwitchUser'ов (Windows XP). Тогда один из пользователей находится в бэкграунде, а другой пользователь имеет в своем распоряжении монитор и клавиатуру. При этом задача пользователя, который работает в бэкграунде - продолжать вычислять.

В многопользовательском варианте использования накладываются некоторые ограничения на использование программы-менеджера. На работу сервиса никаких ограничений не существует, так как программа запускается самой системой при загрузке и работает от имени системного пользователя. Если попытаться запустить несколько экземпляров программы-менеджера на одном компьютере, то все попытки запуска программы кроме первого сообщат пользователю о невозможности их работы и корректно завершатся.

Такое ограничение естественно, поскольку у разных пользователей могут быть разные ключи доступа. Например, пользователь, работающий в бэкграунде, может требовать для компьютера доступ ко всему миру (World), а одновременно с ним работающий другой пользователь (бесправный) может требовать доступ только к городской сети (Local). И в этом случае Key-серверу будет не понятно, какой доступ дать машине, так как доступ предоставляется не пользователям, а машинам. Поэтому надо следить, чтобы в каждый момент времени работал только один экземпляр менеджера.

Работа программы в операционных системах Windows 9x/ME

Существуют некоторые исключения касающиеся использования Botik::Key Pro на таких операционных системах как MS Windows 9x/ME. Так как данные типы ОС не имеют возможности исполнять программу как сервис, на этих операционных системах сервисная часть Botik::Key Pro будет работать как обычное пользовательское приложение, автозапуск которого будет осуществляться на последней стадии загрузки системы. Из этого следует, что пользователи ОС MS Windows 9x/ME не получат никаких выгод от использования Botik::Key Pro, за исключением, возможно, пользовательского интерфейса (GUI). В программе корректно реализована работа с иконкой в поле оповещения панели задач (трей ;-) и контекстным меню этой иконки.

Еще одно исключение касается операционных систем MS Windows 95. В этих операционных системах программа не поддерживает автоматического определения адреса используемого шлюза (gateway). Таким образом, опция "BotikKey сервер установлен на шлюзе" не работает в этих операционных системах. Для того чтобы указать, где установлен сервер, Вам необходимо вручную ввести его адрес в поле "Адрес BotikKey сервера". В следующих версиях я постараюсь добавить поддержку автоматического определения шлюза и в эти операционные системы.

См. также:
Что нового в этой версии?


Техническая поддержка

Автор с удовольствием примет благодарности (в любом виде), сообщения об ошибках (bug reports) и предложения по улучшению программы.

E-mail: botikkeypro@stitch.pereslavl.ru.
Web: http://www.botik.ru/~botik-key-pro/.

Следите за обновлениями и новостями. Вопросы можно задавить по адресу указанному выше.

Для бета-тестеров и не только

Когда сообщаете об ошибке, пожалуйста, указывайте тип своей операционной системы (версию, установленные заплатки), основные характеристики компьютера (CPU, RAM, сетевой адаптер), номер версии Botik::Key Pro. И, очень желательно, алгоритм действий, приводящий к проявлению ошибки.

Все бета-версии (в номере версии присутствует -b) программы собираются с включенным режимом вывода отладочной печати. Для получения вывода отладочной печати предлагаю использовать программу DebugView Марка Руссиновича. Вы можете скачать ее в разделе Download на сайте программы Botik::Key Pro. Для того чтобы не получать отладочную печать от других программ, советую в фильтре программы DebugView указать BKP:*. (Без точки, просто BKP:* ;-)

Стабильные версии (те у которых не присутствует -b в номере версии) собираются с отключенным выводом отладочной печати, но у каждой стабильной версии программы имеется сборка с отладочной печатью (в номере версии присутствует -dbg). Т.о. если Вы заметили ошибку в стабильной версии, то Вы можете установить версию с отладочной печатью. Стабильные версии программы с отладочной печатью предоставляются как zip-архив, т.о. Вы можете просто заменить исполняемые файлы не переустанавливая пакет Botik::Key Pro целиком (не изменяя состояние системы).

Буду очень благодарен, если Вы, когда будете сообщать об ошибке, будете посылать письмо с протоколом выполнения программы сделанным с помощью DebugView, а в теме письма укажете просто слово BUG.


Что нового в этой версии?

Ну вот и вышла в свет следующая версия программы Botik::Key Pro. В ней есть несколько новшеств и, конечно, исправлений ошибок... ;-)

  • Исправлена ошибка, из-за которой Менеджер не запускался у пользователей не имеющих права администратора (ОС Windows NT/2000/XP/2003)
  • Если Менеджер запущен пользователем без прав администратора, то вкладки "Сервис" и "Ключ доступа" будут содержать неактивные элементы управления, так как они отвечают за глобальные настройки сервиса, а не за персональные настройки самой программы Менеджера.
  • Исправлена ошибка, из-за которой если изменить адрес кей-сервера или порт не происходило подключение по новым параметрам.
  • Изменено поведение переключателя доступа. раньше он отображал текущее состояние подключения, т.е. то, что выставил Кей-сервер. Теперь переключатель отображает затребованный уровень доступа, а иконка в "трее" и светофор отображают полученный от Кей-сервера уровень доступа.

Что ожидать в следующих версиях?

  • Оповещение о событиях: всплывающие окошечки с сообщениями, отправка сообщения на удаленную машину, отправка почтового сообщения, ICQ, MSNMessenger...
  • Хуки (hooks) для переключения режима доступа к сети с помощью определяемых пользователем комбинаций горячих клавиш при неактивном окне менеджера. Т.е. при любом активном приложении нажав определенную комбинацию клавиш переключать режим доступа.
  • Поддержку системы безопасности при работе в ОС Windows NT. Только администраторы и пользователь-владелец сервисного процесса может изменять конфигурацию сервиса, уровень доступа к сети и работу сервиса. В общем, можно еще что-нибудь придумать здесь... Посмотрим...
  • Нормальную (правильную) локализацию.
  • Сохранение ключа доступа в переменной окружения.
  • Автоопределение адреса шлюза в операционных системах MS Windows 95.
  • Автоматическое переключение уровня доступа к сети при загрузке приложений. Пользователь сможет создавать список приложений и выставлять для них необходимый минимальный уровень доступа к сети. При загрузке приложения из этого списка, будет выставляться требуемый для этого приложения уровень доступа, если текущий уровень доступа меньше требуемого, если текущий уровень доступа >= требуемого, то ничего не изменяется. При выгрузке приложения, уровень доступа будет восстанавливаться. По поводу этой фичи необходимо еще подумать немного... ;-)
  • Ну и конечно исправление найденных ошибок. А как без них? Если программист написал программу и в ней нет ошибок, значит ошибка в компиляторе... Шутка... ;-)


GNU General Public License (Eng)

Botik::Key Pro: Введение

GNU GENERAL PUBLIC LICENSE
Version 2, June 1991

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA

Everyone is permitted to copy and distribute verbatim copies of this license document, but changing it is not allowed.

Preamble

The licenses for most software are designed to take away your freedom to share and change it. By contrast, the GNU General Public License is intended to guarantee your freedom to share and change free software--to make sure the software is free for all its users. This General Public License applies to most of the Free Software Foundation's software and to any other program whose authors commit to using it. (Some other Free Software Foundation software is covered by the GNU Library General Public License instead.) You can apply it to your programs, too.

When we speak of free software, we are referring to freedom, not price. Our General Public Licenses are designed to make sure that you have the freedom to distribute copies of free software (and charge for this service if you wish), that you receive source code or can get it if you want it, that you can change the software or use pieces of it in new free programs; and that you know you can do these things.

To protect your rights, we need to make restrictions that forbid anyone to deny you these rights or to ask you to surrender the rights. These restrictions translate to certain responsibilities for you if you distribute copies of the software, or if you modify it.

For example, if you distribute copies of such a program, whether gratis or for a fee, you must give the recipients all the rights that you have. You must make sure that they, too, receive or can get the source code. And you must show them these terms so they know their rights.

We protect your rights with two steps: (1) copyright the software, and (2) offer you this license which gives you legal permission to copy, distribute and/or modify the software.

Also, for each author's protection and ours, we want to make certain that everyone understands that there is no warranty for this free software. If the software is modified by someone else and passed on, we want its recipients to know that what they have is not the original, so that any problems introduced by others will not reflect on the original authors' reputations.

Finally, any free program is threatened constantly by software patents. We wish to avoid the danger that redistributors of a free program will individually obtain patent licenses, in effect making the program proprietary. To prevent this, we have made it clear that any patent must be licensed for everyone's free use or not licensed at all.

The precise terms and conditions for copying, distribution and modification follow.

GNU GENERAL PUBLIC LICENSE
TERMS AND CONDITIONS FOR COPYING, DISTRIBUTION AND MODIFICATION

0. This License applies to any program or other work which contains a notice placed by the copyright holder saying it may be distributed under the terms of this General Public License. The "Program", below, refers to any such program or work, and a "work based on the Program" means either the Program or any derivative work under copyright law: that is to say, a work containing the Program or a portion of it, either verbatim or with modifications and/or translated into another language. (Hereinafter, translation is included without limitation in the term "modification".) Each licensee is addressed as "you".

Activities other than copying, distribution and modification are not covered by this License; they are outside its scope. The act of running the Program is not restricted, and the output from the Program is covered only if its contents constitute a work based on the Program (independent of having been made by running the Program). Whether that is true depends on what the Program does.

1. You may copy and distribute verbatim copies of the Program's source code as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the Program a copy of this License along with the Program.

You may charge a fee for the physical act of transferring a copy, and you may at your option offer warranty protection in exchange for a fee.

2. You may modify your copy or copies of the Program or any portion of it, thus forming a work based on the Program, and copy and distribute such modifications or work under the terms of Section 1 above, provided that you also meet all of these conditions:

    a) You must cause the modified files to carry prominent notices stating that you changed the files and the date of any change.

    b) You must cause any work that you distribute or publish, that in whole or in part contains or is derived from the Program or any part thereof, to be licensed as a whole at no charge to all third parties under the terms of this License.

    c) If the modified program normally reads commands interactively when run, you must cause it, when started running for such interactive use in the most ordinary way, to print or display an announcement including an appropriate copyright notice and a notice that there is no warranty (or else, saying that you provide a warranty) and that users may redistribute the program under these conditions, and telling the user how to view a copy of this License. (Exception: if the Program itself is interactive but does not normally print such an announcement, your work based on the Program is not required to print an announcement.)

These requirements apply to the modified work as a whole. If identifiable sections of that work are not derived from the Program, and can be reasonably considered independent and separate works in themselves, then this License, and its terms, do not apply to those sections when you distribute them as separate works. But when you distribute the same sections as part of a whole which is a work based on the Program, the distribution of the whole must be on the terms of this License, whose permissions for other licensees extend to the entire whole, and thus to each and every part regardless of who wrote it.

Thus, it is not the intent of this section to claim rights or contest your rights to work written entirely by you; rather, the intent is to exercise the right to control the distribution of derivative or collective works based on the Program.

In addition, mere aggregation of another work not based on the Program with the Program (or with a work based on the Program) on a volume of a storage or distribution medium does not bring the other work under the scope of this License.

3. You may copy and distribute the Program (or a work based on it, under Section 2) in object code or executable form under the terms of Sections 1 and 2 above provided that you also do one of the following:

    a) Accompany it with the complete corresponding machine-readable source code, which must be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

    b) Accompany it with a written offer, valid for at least three years, to give any third party, for a charge no more than your cost of physically performing source distribution, a complete machine-readable copy of the corresponding source code, to be distributed under the terms of Sections 1 and 2 above on a medium customarily used for software interchange; or,

    c) Accompany it with the information you received as to the offer to distribute corresponding source code. (This alternative is allowed only for noncommercial distribution and only if you received the program in object code or executable form with such an offer, in accord with Subsection b above.)

The source code for a work means the preferred form of the work for making modifications to it. For an executable work, complete source code means all the source code for all modules it contains, plus any associated interface definition files, plus the scripts used to control compilation and installation of the executable. However, as a special exception, the source code distributed need not include anything that is normally distributed (in either source or binary form) with the major components (compiler, kernel, and so on) of the operating system on which the executable runs, unless that component itself accompanies the executable.

If distribution of executable or object code is made by offering access to copy from a designated place, then offering equivalent access to copy the source code from the same place counts as distribution of the source code, even though third parties are not compelled to copy the source along with the object code.

4. You may not copy, modify, sublicense, or distribute the Program except as expressly provided under this License. Any attempt otherwise to copy, modify, sublicense or distribute the Program is void, and will automatically terminate your rights under this License. However, parties who have received copies, or rights, from you under this License will not have their licenses terminated so long as such parties remain in full compliance.

5. You are not required to accept this License, since you have not signed it. However, nothing else grants you permission to modify or distribute the Program or its derivative works. These actions are prohibited by law if you do not accept this License. Therefore, by modifying or distributing the Program (or any work based on the Program), you indicate your acceptance of this License to do so, and all its terms and conditions for copying, distributing or modifying the Program or works based on it.

6. Each time you redistribute the Program (or any work based on the Program), the recipient automatically receives a license from the original licensor to copy, distribute or modify the Program subject to these terms and conditions. You may not impose any further restrictions on the recipients' exercise of the rights granted herein. You are not responsible for enforcing compliance by third parties to this License.

7. If, as a consequence of a court judgment or allegation of patent infringement or for any other reason (not limited to patent issues), conditions are imposed on you (whether by court order, agreement or otherwise) that contradict the conditions of this License, they do not excuse you from the conditions of this License. If you cannot distribute so as to satisfy simultaneously your obligations under this License and any other pertinent obligations, then as a consequence you may not distribute the Program at all. For example, if a patent license would not permit royalty-free redistribution of the Program by all those who receive copies directly or indirectly through you, then the only way you could satisfy both it and this License would be to refrain entirely from distribution of the Program.

If any portion of this section is held invalid or unenforceable under any particular circumstance, the balance of the section is intended to apply and the section as a whole is intended to apply in other circumstances.

It is not the purpose of this section to induce you to infringe any patents or other property right claims or to contest validity of any such claims; this section has the sole purpose of protecting the integrity of the free software distribution system, which is implemented by public license practices. Many people have made generous contributions to the wide range of software distributed through that system in reliance on consistent application of that system; it is up to the author/donor to decide if he or she is willing to distribute software through any other system and a licensee cannot impose that choice.

This section is intended to make thoroughly clear what is believed to be a consequence of the rest of this License.

8. If the distribution and/or use of the Program is restricted in certain countries either by patents or by copyrighted interfaces, the original copyright holder who places the Program under this License may add an explicit geographical distribution limitation excluding those countries, so that distribution is permitted only in or among countries not thus excluded. In such case, this License incorporates the limitation as if written in the body of this License.

9. The Free Software Foundation may publish revised and/or new versions of the General Public License from time to time. Such new versions will be similar in spirit to the present version, but may differ in detail to address new problems or concerns.

Each version is given a distinguishing version number. If the Program specifies a version number of this License which applies to it and "any later version", you have the option of following the terms and conditions either of that version or of any later version published by the Free Software Foundation. If the Program does not specify a version number of this License, you may choose any version ever published by the Free Software Foundation.

10. If you wish to incorporate parts of the Program into other free programs whose distribution conditions are different, write to the author to ask for permission. For software which is copyrighted by the Free Software Foundation, write to the Free Software Foundation; we sometimes make exceptions for this. Our decision will be guided by the two goals of preserving the free status of all derivatives of our free software and of promoting the sharing and reuse of software generally.

NO WARRANTY

11. BECAUSE THE PROGRAM IS LICENSED FREE OF CHARGE, THERE IS NO WARRANTY FOR THE PROGRAM, TO THE EXTENT PERMITTED BY APPLICABLE LAW. EXCEPT WHEN OTHERWISE STATED IN WRITING THE COPYRIGHT HOLDERS AND/OR OTHER PARTIES PROVIDE THE PROGRAM "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK AS TO THE QUALITY AND PERFORMANCE OF THE PROGRAM IS WITH YOU. SHOULD THE PROGRAM PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, REPAIR OR CORRECTION.

12. IN NO EVENT UNLESS REQUIRED BY APPLICABLE LAW OR AGREED TO IN WRITING WILL ANY COPYRIGHT HOLDER, OR ANY OTHER PARTY WHO MAY MODIFY AND/OR REDISTRIBUTE THE PROGRAM AS PERMITTED ABOVE, BE LIABLE TO YOU FOR DAMAGES, INCLUDING ANY GENERAL, SPECIAL, INCIDENTAL OR CONSEQUENTIAL DAMAGES ARISING OUT OF THE USE OR INABILITY TO USE THE PROGRAM (INCLUDING BUT NOT LIMITED TO LOSS OF DATA OR DATA BEING RENDERED INACCURATE OR LOSSES SUSTAINED BY YOU OR THIRD PARTIES OR A FAILURE OF THE PROGRAM TO OPERATE WITH ANY OTHER PROGRAMS), EVEN IF SUCH HOLDER OR OTHER PARTY HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES.

END OF TERMS AND CONDITIONS

How to Apply These Terms to Your New Programs

If you develop a new program, and you want it to be of the greatest possible use to the public, the best way to achieve this is to make it free software which everyone can redistribute and change under these terms.

To do so, attach the following notices to the program. It is safest to attach them to the start of each source file to most effectively convey the exclusion of warranty; and each file should have at least the "copyright" line and a pointer to where the full notice is found.

    <one line to give the program's name and a brief idea of what it does.>
    Copyright (C) 19yy <name of author>

    This program is free software; you can redistribute it and/or modify
    it under the terms of the GNU General Public License as published by
    the Free Software Foundation; either version 2 of the License, or
    (at your option) any later version.

    This program is distributed in the hope that it will be useful,
    but WITHOUT ANY WARRANTY; without even the implied warranty of
    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
    GNU General Public License for more details.

    You should have received a copy of the GNU General Public License
    along with this program; if not, write to the Free Software
    Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA

Also add information on how to contact you by electronic and paper mail.

If the program is interactive, make it output a short notice like this when it starts in an interactive mode:

    Gnomovision version 69, Copyright (C) 19yy name of author
    Gnomovision comes with ABSOLUTELY NO WARRANTY; for details type `show w'.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `show c' for details.

The hypothetical commands `show w' and `show c' should show the appropriate parts of the General Public License. Of course, the commands you use may be called something other than `show w' and `show c'; they could even be mouse-clicks or menu items--whatever suits your program.

You should also get your employer (if you work as a programmer) or your school, if any, to sign a "copyright disclaimer" for the program, if necessary. Here is a sample; alter the names:

    Yoyodyne, Inc., hereby disclaims all copyright interest in the program
    `Gnomovision' (which makes passes at compilers) written by James Hacker.

    <signature of Ty Coon>, 1 April 1989
    Ty Coon, President of Vice

This General Public License does not permit incorporating your program into proprietary programs. If your program is a subroutine library, you may consider it more useful to permit linking proprietary applications with the library. If this is what you want to do, use the GNU Library General Public License instead of this License.


GNU General Public License (Eng)

Botik::Key Pro: Введение

GPL RUSSIAN TRANSLATION

ПЕРЕВОД НА РУССКИЙ ЯЗЫК GENERAL PUBLIC LICENSE GNU
Автор перевода Елена Тяпкина [tiapkina@hotmail.com], 20-Mar-2002

This is an unofficial translation of the GNU General Public License into Russian. It was not published by the Free Software Foundation, and does not legally state the distribution terms for software that uses the GNU GPL - only the original English text of the GNU GPL does that. However, we hope that this translation will help Russian speakers understand the GNU GPL better.

Настоящий перевод Стандартной Общественной Лицензии GNU на русский язык не является официальным. Он не публикуется Free Software Foundation и не устанавливает имеющих юридическую силу условий для распространения программного обеспечения, которое распространяется на условиях Стандартной Общественной Лицензии GNU. Условия, имеющие юридическую силу, закреплены исключительно в аутентичном тексте Стандартной Общественной Лицензии GNU на английском языке. Я надеюсь, что настоящий перевод поможет русскоязычным пользователям лучше понять содержание Стандартной Общественной Лицензии GNU.

Текст GNU GPL на английском языке вы можете прочитать здесь: http://www.gnu.org/copyleft/gpl.html

GNU GENERAL PUBLIC LICENSE
Версия 2, июнь 1991г.

Copyright (C) 1989, 1991 Free Software Foundation, Inc. 59 Temple Place, Suite 330, Boston, MA 02111-1307, USA

Каждый вправе копировать и распространять экземпляры настоящей Лицензии без внесения изменений в ее текст.

Преамбула

Большинство лицензий на программное обеспечение лишаeт вас права распространять и вносить изменения в это программное обеспечение. Стандартная Общественная Лицензия GNU, напротив, разработана с целью гарантировать вам право совместно использовать и вносить изменения в свободное программное обеспечение, т.е. обеспечить свободный доступ к программному обеспечению для всех пользователей. Условия настоящей Стандартной Общественной Лицензии применяются к большей части программного обеспечения Free Software Foundation, а также к любому другому программному обеспечению по желанию его автора. (К некоторому программному обеспечению Free Software Foundation применяются условия Стандартной Общественной Лицензии GNU для Библиотек). Вы также можете применять Стандартную Общественную Лицензию к разработанному вами программному обеспечению.

Говоря о свободном программном обеспечении, мы имеем в виду свободу, а не безвозмездность. Настоящая Стандартная Общественная Лицензия разработана с целью гарантировать вам право распространять экземпляры свободного программного обеспечения (и при желании получать за это вознаграждение), право получать исходный текст программного обеспечения или иметь возможность его получить, право вносить изменения в программное обеспечение или использовать его части в новом свободном программном обеспечении, а также право знать, что вы имеете все вышеперечисленные права.

Чтобы защитить ваши права, мы вводим ряд ограничений с тем, чтобы никто не имел возможности лишить вас этих прав или обратиться к вам с предложением отказаться от этих прав. Данные ограничения налагают на вас определенные обязанности в случае, если вы распространяете экземпляры программного обеспечения или модифицируете программное обеспечение.

Например, если вы распространяете экземпляры такого программного обеспечения за плату или бесплатно, вы обязаны передать новым обладателям все права в том же объеме, в каком они принадлежат вам. Вы обязаны обеспечить получение новыми обладателями программы ее исходного текста или возможность его получить. Вы также обязаны ознакомить их с условиями настоящей Лицензии.

Для защиты ваших прав мы: (1) оставляем за собой авторские права на программное обеспечение и (2) предлагаем вам использовать настоящую Лицензию, в соответствии с условиями которой вы вправе воспроизводить, распространять и/или модифицировать программное обеспечение.

Кроме того, для защиты как нашей репутации, так и репутации других авторов программного обеспечения, мы уведомляем всех пользователей, что на данное программное обеспечение никаких гарантий не предоставляется. Те, кто приобрел программное обеспечение, с внесенными в него третьими лицами изменениями, должны знать, что они получают не оригинал, в силу чего автор оригинала не несет ответственности за ошибки в работе программного обеспечения, допущенные третьими лицами при внесении изменений.

Наконец, программное обеспечение перестает быть свободным в случае, если лицо приобретает на него исключительные права [1]. Недопустимо, чтобы лица, распространяющие свободное программное обеспечение, могли приобрести исключительные права на использование данного программного обеспечения и зарегистрировать их в Патентном ведомстве. Чтобы избежать этого, мы заявляем, что обладатель исключительных прав обязан предоставить любому лицу права на использование программного обеспечения либо не приобретать исключительных прав вообще.

Ниже изложены условия воспроизведения, распространения и модификации программного обеспечения.

GNU GENERAL PUBLIC LICENSE
УСЛОВИЯ ВОСПРОИЗВЕДЕНИЯ, РАСПРОСТРАНЕНИЯ И МОДИФИКАЦИИ

0. Условия настоящей Лицензии применяются ко всем видам программного обеспечения или любому иному произведению, которое содержит указание правообладателя на то, что данное произведение может распространяться на условиях Стандартной Общественной Лицензии. Под термином "Программа" далее понимается любое подобное программное обеспечение или иное произведение. Под термином "произведение, производное от Программы" понимается Программа или любое иное производное произведение в соответствии с законодательством об авторском праве [2], т.е. произведение, включающее в себя Программу или ее часть, как с внесенными в ее текст изменениями, так и без них и/или переведенную на другой язык. (Здесь и далее, понятие "модификация" включает в себя понятие перевода в самом широком смысле). Каждый приобретатель экземпляра Программы именуется в дальнейшем "Лицензиат".

Действие настоящей Лицензии не распространяется на осуществление иных прав, кроме воспроизведения, распространения и модификации программного обеспечения. Не устанавливается ограничений на запуск Программы. Условия Лицензии распространяются на выходные данные из Программы только в том случае, если их содержание составляет произведение, производное от Программы (независимо от того, было ли такое произведение создано в результате запуска Программы). Это зависит от того, какие функции выполняет Программа.

1. Лицензиат вправе изготовлять и распространять экземпляры исходного текста Программы в том виде, в каком он его получил, без внесения в него изменений на любом носителе, при соблюдении следующих условий: на каждом экземпляре помещен знак охраны авторского права и уведомление об отсутствии гарантий; оставлены без изменений все уведомления, относящиеся к настоящей Лицензии и отсутствию гарантий; вместе с экземпляром Программы приобретателю передается копия настоящей Лицензии.

Лицензиат вправе взимать плату за передачу экземпляра Программы, а также вправе за плату оказывать услуги по гарантийной поддержке Программы.

2. Лицензиат вправе модифицировать свой экземпляр или экземпляры Программы полностью или любую ее часть. Данные действия Лицензиата влекут за собой создание произведения, производного от Программы. Лицензиат вправе изготовлять и распространять экземпляры такого произведения, производного от Программы, или собственно экземпляры изменений в соответствии с пунктом 1 настоящей Лицензии при соблюдении следующих условий:

    а) файлы, измененные Лицензиатом, должны содержать хорошо заметную пометку, что они были изменены, а также дату внесения изменений;

    b) при распространении или публикации Лицензиатом любого произведения, которое содержит Программу или ее часть или является производным от Программы или от ее части, Лицензиат обязан передавать права на использование данного произведения третьим лицам на условиях настоящей Лицензии, при этом Лицензиат не вправе требовать уплаты каких-либо лицензионных платежей. Распространяемое произведение лицензируется как одно целое;

    c) если модифицированная Программа при запуске обычно читает команды в интерактивном режиме, Лицензиат обязан обеспечить вывод на экран дисплея или печатающее устройство сообщения, которое должно включать в себя: знак охраны авторского права; уведомление об отсутствии гарантий на Программу (или иное, если Лицензиат предоставляет гарантии); указание на то, что пользователи вправе распространять экземпляры Программы в соответствии с условиями настоящей Лицензии, а также на то, каким образом пользователь может ознакомиться с текстом настоящей Лицензии. (Исключение: если оригинальная Программа является интерактивной, но не выводит в своем обычном режиме работы сообщение такого рода, то вывод подобного сообщения произведением, производным от Программы, в этом случае не обязателен).

Вышеуказанные условия применяются к модифицированному произведению, производному от Программы, в целом. В случае если отдельные части данного произведения не являются производными от Программы, являются результатом творческой деятельности и могут быть использованы как самостоятельное произведение, Лицензиат вправе распространять отдельно такое произведение на иных лицензионных условиях. В случае если Лицензиат распространяет вышеуказанные части в составе произведения, производного от Программы, то условия настоящей Лицензии применяются к произведению в целом, при этом права, приобретаемые сублицензиатами на основании Лицензии, передаются им в отношении всего произведения, включая все его части, независимо от того, кто является их авторами.

Целью настоящего пункта 2 не является заявление прав или оспаривание прав на произведение, созданное исключительно Лицензиатом. Целью настоящего пункта является обеспечение права контролировать распространение произведений, производных от Программы, и составных произведений, производных от Программы.

Размещение произведения, которое не является производным от Программы, на одном устройстве для хранения информации или носителе вместе с Программой или произведением, производным от Программы, не влечет за собой распространения условий настоящей Лицензии на такое произведение.

3. Лицензиат вправе воспроизводить и распространять экземпляры Программы или произведения, которое является производным от Программы, в соответствии с пунктом 2 настоящей Лицензии, в виде объектного кода или в исполняемой форме в соответствии с условиями п.п.1 и 2 настоящей Лицензии при соблюдении одного из перечисленных ниже условий:

    а) к экземпляру должен прилагаться соответствующий полный исходный текст в машиночитаемой форме, который должен распространяться в соответствии с условиями п.п. 1 и 2 настоящей Лицензии на носителе, обычно используемом для передачи программного обеспечения, либо

    b) к экземпляру должно прилагаться действительное в течение трех лет предложение в письменной форме к любому третьему лицу передать за плату, не превышающую стоимость осуществления собственно передачи, экземпляр соответствующего полного исходного текста в машиночитаемой форме в соответствии с условиями п.п. 1 и 2 настоящей Лицензии на носителе, обычно используемом для передачи программного обеспечения, либо

    c) к экземпляру должна прилагаться полученная Лицензиатом информация о предложении, в соответствии с которым можно получить соответствующий исходный текст. (Данное положение применяется исключительно в том случае, если Лицензиат осуществляет некоммерческое распространение программы, при этом программа была получена самим Лицензиатом в виде объектного кода или в исполняемой форме и сопровождалась предложением, соответствующим условиям пп.b п.3 настоящей Лицензии).

Под исходным текстом произведения понимается такая форма произведения, которая наиболее удобна для внесения изменений. Под полным исходным текстом исполняемого произведения понимается исходный текст всех составляющих произведение модулей, а также всех файлов, связанных с описанием интерфейса, и сценариев, предназначенных для управления компиляцией и установкой исполняемого произведения. Однако, в качестве особого исключения, распространяемый исходный текст может не включать того, что обычно распространяется (в виде исходного текста или в бинарной форме) с основными компонентами (компилятор, ядро и т.д.) операционной системы, в которой работает исполняемое произведение, за исключением случаев, когда исполняемое произведение сопровождается таким компонентом.

В случае если произведение в виде объектного кода или в исполняемой форме распространяется путем предоставления доступа для копирования его из определенного места, обеспечение равноценного доступа для копирования исходного текста из этого же места удовлетворяет требованиям распространения исходного текста, даже если третьи лица при этом не обязаны копировать исходный текст вместе с объектным кодом произведения.

4. Лицензиат вправе воспроизводить, модифицировать, распространять или передавать права на использование Программы только на условиях настоящей Лицензии. Любое воспроизведение, модификация, распространение или передача прав на иных условиях являются недействительными и автоматически ведут к расторжению настоящей Лицензии и прекращению всех прав Лицензиата, предоставленных ему настоящей Лицензией. При этом права третьих лиц, которым Лицензиат в соответствии с настоящей Лицензией передал экземпляры Программы или права на нее, сохраняются в силе при условии полного соблюдения ими настоящей Лицензии.

5. Лицензиат не обязан присоединяться к настоящей Лицензии, поскольку он ее не подписал. Однако только настоящая Лицензия предоставляет право распространять или модифицировать Программу или произведение, производное от Программы. Подобные действия нарушают действующее законодательство, если они не осуществляются в соответствии с настоящей Лицензией. Если Лицензиат внес изменения или осуществил распространение экземпляров Программы или произведения, производного от Программы, Лицензиат тем самым подтвердил свое присоединение к настоящей Лицензии в целом, включая условия, определяющие порядок воспроизведения, распространения или модификации Программы или произведения, производного от Программы.

6. При распространении экземпляров Программы или произведения, производного от Программы, первоначальный лицензиар автоматически передает приобретателю такого экземпляра право воспроизводить, распространять и модифицировать Программу в соответствии с условиями настоящей Лицензии. Лицензиат не вправе ограничивать каким-либо способом осуществление приобретателями полученных ими прав. Лицензиат не несет ответственности за несоблюдение условий настоящей Лицензии третьими лицами.

7. Лицензиат не освобождается от исполнения обязательств в соответствии с настоящей Лицензией в случае, если в результате решения суда или заявления о нарушении исключительных прав или в связи с наступлением иных обстоятельств, не связанных непосредственно с нарушением исключительных прав, на Лицензиата на основании решения суда, договора или ином основании возложены обязательства, которые противоречат условиям настоящей Лицензии. В этом случае Лицензиат не вправе распространять экземпляры Программы, если он не может одновременно исполнить условия настоящей Лицензии и возложенные на него указанным выше способом обязательства. Например, если по условиям лицензионного соглашения сублицензиатам не может быть предоставлено право бесплатного распространения экземпляров Программы, которые они приобрели напрямую или через третьих лиц у Лицензиата, то в этом случае Лицензиат обязан отказаться от распространения экземпляров Программы.

Если любое положение настоящего пункта при наступлении конкретных обстоятельств будет признано недействительным или неприменимым, настоящий пункт применяется за исключением такого положения. Настоящий пункт применяется в целом при прекращении вышеуказанных обстоятельств или их отсутствии.

Целью данного пункта не является принуждение Лицензиата к нарушению патента или заявления на иные права собственности или к оспариванию действительности такого заявления. Единственной целью данного пункта является защита неприкосновенности системы распространения свободного программного обеспечения, которая обеспечивается за счет общественного лицензирования. Многие люди внесли свой щедрый вклад в создание большого количества программного обеспечения, которое распространяется через данную систему в надежде на ее длительное и последовательное применение. Лицензиат не вправе вынуждать автора распространять программное обеспечение через данную систему. Право выбора системы распространения программного обеспечения принадлежит исключительно его автору.

Настоящий пункт 7 имеет целью четко определить те цели, которые преследуют все остальные положения настоящей Лицензии.

8. В том случае если распространение и/или использование Программы в отдельных государствах ограничено соглашениями в области патентных или авторских прав, первоначальный правообладатель, распространяющий Программу на условиях настоящей Лицензии, вправе ограничить территорию распространения Программы, указав только те государства, на территории которых допускается распространение Программы без ограничений, обусловленных такими соглашениями. В этом случае такое указание в отношении территорий определенных государств признается одним из условий настоящей Лицензии.

9. Free Software Foundation может публиковать исправленные и/или новые версии настоящей Стандартной Общественной Лицензии. Такие версии могут быть дополнены различными нормами, регулирующими правоотношения, которые возникли после опубликования предыдущих версий, однако в них будут сохранены основные принципы, закрепленные в настоящей версии.

Каждой версии присваивается свой собственный номер. Если указано, что Программа распространяется в соответствии с определенной версией, т.е. указан ее номер, или любой более поздней версией настоящей Лицензии, Лицензиат вправе присоединиться к любой из этих версий Лицензии, опубликованных Free Software Foundation. Если Программа не содержит такого указания на номер версии Лицензии Лицензиат вправе присоединиться к любой из версий Лицензии, опубликованных когда-либо Free Software Foundation.

10. В случае если Лицензиат намерен включить часть Программы в другое свободное программное обеспечение, которое распространяется на иных условиях, чем в настоящей Лицензии, ему следует испросить письменное разрешение на это у автора программного обеспечения. Разрешение в отношении программного обеспечения, права на которое принадлежат Free Software Foundation, следует испрашивать у Free Software Foundation. В некоторых случаях Free Software Foundation делает исключения. При принятии решения Free Software Foundation будет руководствоваться двумя целями: сохранение статуса свободного для любого произведения, производного от свободного программного обеспечения Free Software Foundation и обеспечение наиболее широкого совместного использования программного обеспечения.

ОТСУТСТВИЕ ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ

11. ПОСКОЛЬКУ НАСТОЯЩАЯ ПРОГРАММА РАСПРОСТРАНЯЕТСЯ БЕСПЛАТНО, ГАРАНТИИ НА НЕЕ НЕ ПРЕДОСТАВЛЯЮТСЯ В ТОЙ СТЕПЕНИ, В КАКОЙ ЭТО ДОПУСКАЕТСЯ ПРИМЕНИМЫМ ПРАВОМ. НАСТОЯЩАЯ ПРОГРАММА ПОСТАВЛЯЕТСЯ НА УСЛОВИЯХ "КАК ЕСТЬ". ЕСЛИ ИНОЕ НЕ УКАЗАНО В ПИСЬМЕННОЙ ФОРМЕ, АВТОР И/ИЛИ ИНОЙ ПРАВООБЛАДАТЕЛЬ НЕ ПРИНИМАЕТ НА СЕБЯ НИКАКИХ ГАРАНТИЙНЫХ ОБЯЗАТЕЛЬСТВ, КАК ЯВНО ВЫРАЖЕННЫХ, ТАК И ПОДРАЗУМЕВАЕМЫХ, В ОТНОШЕНИИ ПРОГРАММЫ, В ТОМ ЧИСЛЕ ПОДРАЗУМЕВАЕМУЮ ГАРАНТИЮ ТОВАРНОГО СОСТОЯНИЯ ПРИ ПРОДАЖЕ И ПРИГОДНОСТИ ДЛЯ ИСПОЛЬЗОВАНИЯ В КОНКРЕТНЫХ ЦЕЛЯХ, А ТАКЖЕ ЛЮБЫЕ ИНЫЕ ГАРАНТИИ. ВСЕ РИСКИ, СВЯЗАННЫЕ С КАЧЕСТВОМ И ПРОИЗВОДИТЕЛЬНОСТЬЮ ПРОГРАММЫ, НЕСЕТ ЛИЦЕНЗИАТ. В СЛУЧАЕ ЕСЛИ В ПРОГРАММЕ БУДУТ ОБНАРУЖЕНЫ НЕДОСТАТКИ, ВСЕ РАСХОДЫ, СВЯЗАННЫЕ С ТЕХНИЧЕСКИМ ОБСЛУЖИВАНИЕМ, РЕМОНТОМ ИЛИ ИСПРАВЛЕНИЕМ ПРОГРАММЫ, НЕСЕТ ЛИЦЕНЗИАТ.

12. ЕСЛИ ИНОЕ НЕ ПРЕДУСМОТРЕНО ПРИМЕНЯЕМЫМ ПРАВОМ ИЛИ НЕ СОГЛАСОВАНО СТОРОНАМИ В ДОГОВОРЕ В ПИСЬМЕННОЙ ФОРМЕ, АВТОР И/ИЛИ ИНОЙ ПРАВООБЛАДАТЕЛЬ, КОТОРЫЙ МОДИФИЦИРУЕТ И/ИЛИ РАСПРОСТРАНЯЕТ ПРОГРАММУ НА УСЛОВИЯХ НАСТОЯЩЕЙ ЛИЦЕНЗИИ, НЕ НЕСЕТ ОТВЕТСТВЕННОСТИ ПЕРЕД ЛИЦЕНЗИАТОМ ЗА УБЫТКИ, ВКЛЮЧАЯ ОБЩИЕ, РЕАЛЬНЫЕ, ПРЕДВИДИМЫЕ И КОСВЕННЫЕ УБЫТКИ (В ТОМ ЧИСЛЕ УТРАТУ ИЛИ ИСКАЖЕНИЕ ИНФОРМАЦИИ, УБЫТКИ, ПОНЕСЕННЫЕ ЛИЦЕНЗИАТОМ ИЛИ ТРЕТЬИМИ ЛИЦАМИ, НЕВОЗМОЖНОСТЬ РАБОТЫ ПРОГРАММЫ С ЛЮБОЙ ДРУГОЙ ПРОГРАММОЙ И ИНЫЕ УБЫТКИ). АВТОР И/ИЛИ ИНОЙ ПРАВООБЛАДАТЕЛЬ В СООТВЕТСТВИИ С НАСТОЯЩИМ ПУНКТОМ НЕ НЕСУТ ОТВЕТСТВЕННОСТИ ДАЖЕ В ТОМ СЛУЧАЕ, ЕСЛИ ОНИ БЫЛИ ПРЕДУПРЕЖДЕНЫ О ВОЗМОЖНОСТИ ВОЗНИКНОВЕНИЯ ТАКИХ УБЫТКОВ.

КОНЕЦ УСЛОВИЙ

Порядок применения условий Стандартной Общественной
Лицензии к созданной вами программе

Если вы создали новую программу и хотите, чтобы она принесла наибольшую пользу обществу, лучший способ достичь этого - сделать вашу программу свободной, когда каждый сможет распространять ее и вносить в нее изменения в соответствии с условиями настоящей Лицензии.

В этих целях Программа должна содержать приведенное ниже уведомление. Наиболее правильным будет поместить его в начале исходного текста каждого файла для максимально ясного указания на то, что гарантии на данную программу не предоставляются. Каждый файл в любом случае должен содержать знак охраны авторского права и пояснение, где можно ознакомиться с полным текстом уведомления.

    <одна строка с наименованием Программы и кратким описанием ее назначения.>
    (C) имя <наименование> автора или иного правообладателя,
    год первого опубликования программы

    Данная программа является свободным программным обеспечением. Вы вправе
    распространять ее и/или модифицировать в соответствии с условиями версии 2 либо
    по вашему выбору с условиями более поздней версии Стандартной Общественной
    Лицензии GNU, опубликованной Free Software Foundation.

    Эта программа распростся в надежде на то, что она будет вам полезной, однако НЕ
    ПРЕДОСТАВЛЯЕМ НА НЕЕ НИКАКИХ ГАРАНТИЙ, в том числе ГАРАНТИИ ТОВАРНОГО СОСТОЯНИЯ
    ПРИ ПРОДАЖЕ и ПРИГОДНОСТИ ДЛЯ ИСПОЛЬЗОВАНИЯ В КОНКРЕТНЫХ ЦЕЛЯХ. Для получения
    более подробной информации ознакомьтесь со Стандартной Общественной Лицензией
    GNU.

    Вместе с данной программой вы должны были получить экземпляр Стандартной
    Общественной Лицензии GNU. Если вы его не получили, сообщите об этом в Free
    Software Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307,
    USA.

Также укажите, как можно связаться с вами по электронной или обычной почте.

Если программа работает в интерактивном режиме, сделайте так, чтобы при запуске в интерактивном режиме выводилось короткое сообщение в соответствии с образцом:

    Gnomovision version 69, © имя автора, год первого опубликования программы
    Gnomovision распространяется БЕЗ ВСЯКИХ ГАРАНТИЙ; чтобы ознакомиться с
    более подробной информацией, наберите "show w". Данная программа является
    свободным программным обеспечением и вы можете распространять ее в
    соответствии с условиями Стандартной Общественной Лицензии GNU. Для
    получения более подробной информации, наберите "show c".

При введении предлагаемых команд "show w" и "show c" на экран должны выводиться соответствующие пункты Стандартной Общественной Лицензии. Не обязательно использовать именно команды "show w" и "show c". В зависимости от функций программы, команды могут вызываться нажатием кнопки мыши или быть добавлены в меню программы.

Если вы создали программу в порядке выполнения служебных обязанностей или служебного задания работодателя либо для образовательного учреждения (школы, ВУЗа и т.д.) в период обучения или работы в данном образовательном учреждении, вам следует получить в случае необходимости письменный отказ от исключительных прав на использование данной программы [3]. Нижеприведенный текст вы можете использовать в качестве образца, заменив соответствующие имена и наименования:

    ЗАО "АБВ" настоящим отказывается от всех исключительных прав на использование программы для ЭВМ "Gnomovision", автором которой является Иванов Алексей Петрович, и передает все исключительные права на использование указанной программы ее автору, Иванову Алексею Петровичу.

    Подпись руководителя организации, печать, 1 января 2001г.
    [Фамилия, Имя, Отчество], Генеральный директор

Стандартная Общественная Лицензия GNU запрещает включать вашу программу в программы, использование которых ограничено их правообладателями. Если ваша программа является библиотекой подпрограмм, вероятно, более полезным будет разрешить связывание программ, использование которых ограничено их правообладателями, с вашей библиотекой. В этом случае вам следует использовать Стандартную Общественную Лицензию GNU для Библиотек вместо настоящей Лицензии.

Примечания переводчика:
[1] - в параграфе 7 Преамбулы в английском тексте Стандартной Общественной Лицензии GNU упоминается патент на программное обеспечение (Software Patents). В начале 90х годов XX века Апелляционный суд Федерального округа США предпринял попытку установить, когда изобретение, частью которого является программное обеспечение, является патентоспособным. Суд постановил, что в этом случае следует провести экспертизу в отношении произведения в целом. Изобретение не будет признано патентоспособным, если оно представляет собой исключительно математический алгоритм. Однако, если положенный в основу изобретения способ при помощи программного обеспечения позволяет получить конкретные, промышленно применимые результаты, в этом случае изобретение является патентоспособным. В отличие от США, в РФ в соответствии с Патентным законом от 23.09.1992г. не признаются патентоспособными изобретениями программы для вычислительных машин. Защита программ для ЭВМ осуществляется на основании норм законодательства об авторском праве. Исключительные права на программу для ЭВМ принадлежат автору или иному правообладателю, который приобрел их на основании договора или ином основании, предусмотренном законом. Правообладатель всех имущественных прав на программу для ЭВМ в течение срока действия авторского права может по своему желанию зарегистрировать программу для ЭВМ путем подачи заявки в Патентное ведомство РФ

[2] - Здесь имеется в виду национальное законодательство страны лицензиара.

[3] - В соответствии с Законом РФ "Об авторском праве и смежных правах" авторское право на произведение, созданное в порядке выполнения служебных обязанностей или служебного задания работодателя (служебное произведение), принадлежит автору служебного произведения. Исключительные права на использование служебного произведения (в том числе программы для ЭВМ) принадлежат лицу, с которым автор состоит в трудовых отношениях (работодателю), если в договоре между ними и автором не предусмотрено иное. Данное положение не распространяется на создание в порядке выполнения служебных обязанностей или служебного задания работодателя энциклопедий, энциклопедических словарей, периодических и продолжающихся сборников научных трудов, газет, журналов и других периодических изданий. Издателю энциклопедий, энциклопедических словарей, периодических и продолжающихся изданий принадлежат исключительные права на использование таких изданий. Авторы произведений, включенных в такие издания, сохраняют исключительные права на использование своих произведений независимо от издания в целом.

В соответствии с п.7 ст. 39 Закона РФ "Об образовании" образовательному учреждению принадлежит право собственности в том числе на продукты интеллектуального и творческого труда, являющиеся результатом деятельности образовательного учреждения. Аналогичная норма содержится в Федеральном законе РФ "О высшем и послевузовском профессиональном образовании" (ФЗ от 22 августа 1996г. № 125-ФЗ).

My goal was not just a verbal translation of English text of GNU General Public License in Russian, but a translation, which will follow the rules of current legislation of Russian Federation on copyrights. I hope that this will help to use GNU General Public License when distributing free software in Russian Federation. Below you may find some comments (in Russian) on current legislation of Russian Federation.

Моей целью был не просто перевод Стандартной Общественной Лицензии GNU, который бы максимально точно соответствовал аутентичному тексту на английском языке, но также учитывал нормы действующего законодательства РФ об авторском праве, что увеличило бы возможность использовать Стандартную Общественную Лицензию GPL для распространения свободного программного обеспечения на территории РФ. Ниже Вы можете ознакомиться с некоторыми комментариями относительно действующего законодательства РФ.

В настоящее время на территории Российской Федерации порядок воспроизведения, распространения и модификации программного обеспечения регулируется Законом РФ "О правовой охране программ для ЭВМ и баз данных" от 23.09.1992г. №3523-1 и Законом РФ "Об авторском праве и смежных правах" от 09.07.1993г. №5351-1. С целью наибольшего соответствия настоящего неофициального перевода Стандартной Общественной Лицензии GNU на русский язык нормам действующего законодательства РФ об авторском праве, ниже приводятся основные понятие, используемые в тексте перевода, и их определения в соответствии с указанными выше Законами РФ: Программное обеспечение - данное понятие не применяется в указанных Законах, однако оно является наиболее общепринятым при обозначении программ для ЭВМ в переводах лицензионных соглашений, в частности Лицензионных соглашений с конечным пользователем (EULA), на русский язык. В силу этого понятие "Программное обеспечение" используется в тексте перевода для обозначения понятия "программа для ЭВМ". Под программой для ЭВМ в Законе РФ понимается объективная форма представления совокупности данных и команд, предназначенных для функционирования электронных вычислительных машин (ЭВМ) и других компьютерных устройств с целью получения определенного результата, включая подготовительные материалы, полученные в ходе разработки программы для ЭВМ, и порождаемые ею аудиовизуальные отображения.

Исключительные права на использование произведения -- означает право осуществлять или разрешать следующие действия: воспроизводить произведение (право на воспроизведение); распространять экземпляры произведения любым способом: продавать, сдавать в прокат и так далее (право на распространение); публично показывать произведение (право на публичный показ), переводить произведение (право на перевод); переделывать, аранжировать или другим образом перерабатывать произведение (право на переработку), а также иные права в соответствии с Законом РФ "Об авторском праве и смежных правах".

Исключительные (или имущественные) права на использование программы для ЭВМ - означает исключительное право осуществлять и (или) разрешать осуществление следующих действий: выпуск в свет программы для ЭВМ, воспроизведение программы для ЭВМ (полное или частичное) в любой форме, любыми способами, распространение программы для ЭВМ, модификацию программы для ЭВМ, в том числе перевод программы для ЭВМ с одного языка на другой, а также иное использование в соответствии с Законом РФ "О правовой охране программ для ЭВМ и баз данных". Воспроизведение Программного Обеспечения -- это изготовление одного или более экземпляров Программного обеспечения в любой материальной форме, а также его запись в память ЭВМ.

Модификация (переработка) Программного Обеспечения - любые его изменения, не являющиеся адаптацией.

Распространение Программного Обеспечения -- это предоставление доступа для воспроизведения в любой материальной форме Программного Обеспечения, в том числе сетевыми и иными способами, а также путем продажи, проката, сдачи в наем, предоставление взаймы, включая импорт для любой из этих целей.

(C) Елена Тяпкина, 2001г.


Ликбез по информационной безопасности

Про необходимость самообразования по информационной безопасности

Мы живем в такое время, когда любой пользователь компьютера обязан обладать приличными знаниями по информационной безопасности. Мы не можем в полной мере изложить здесь данную область знаний. Коснемся лишь азов, и то, только того, что связано с программой Botik Key и с исключением "кражи трафика" у Вас. Все остальное мы рекомендуем Вам изучать самостоятельно в книгах, журналах и в Интернете.

Исключает ли Botik Key возможность кражи трафика?

Будем говорить, что злоумышленник крадет у Вас трафик, если ему удалось сделать так, что он работает с Сетью за Ваш счет. Другими словами, если Вы оплачиваете получаемые им услуги связи.

Использование системы Botik Key дает Вам полную гарантию, что злоумышленник не сможет у Вас украсть трафик до тех пор, пока Вы соблюдаете элементарные правила информационной безопасности -- пока Вы не даете злоумышленнику одну из двух возможностей:

  1. возможность украсть у Вас пароль (ключ) доступа к Сети;
  2. возможность работать со своего компьютера через Ваш компьютер.

Тем самым, Вам необходимо самостоятельно следить за тем, чтобы не случились эти две неприятности.


Разбор угрозы: кража пароля (ключа) доступа к Сети

После кражи Вашего
пароля (ключа) доступа
злоумышленник может
свой компьютер (справа)
сделать трудноотличимым
от Вашего (слева)

Возможные последствия

После кражи у Вас пароля (ключа) доступа к Сети, злоумышленник получает возможность выдавать свой компьютер за Ваш компьютер: он сможет установить на своем компьютере сетевые настройки, совпадающие с настройками Вашего компьютера, запустить программу Botik Key и использовать украденный пароль (ключ).

После этого его компьютер может оказаться ничем не отличим (или трудно отличим) от Вашего. Соответственно, вся стоимость получаемых им услуг связи будет относиться на Ваш счет.

Меры исправления ситуации

Если у Вас возникли подозрения, что некий злоумышленник украл у Вас пароль (ключ) доступа к Сети, то Вам следует:

  • сообщить о Ваших подозрениях на support@botik.ru;
  • затем немедленно поменять Ваш пароль доступа к Сети;
  • в дальнейшем соблюдать профилактические меры.

Меры профилактики: как сберечь пароль от злоумышленника?

Общие принципы:

  • Надо хранить пароль (ключ) в местах, недоступных для посторонних (а лучше--в местах, недоступных всем, кроме Вас).
  • Надо использовать пароль (ключ) доступа к Сети так, чтобы исключить вероятность "перехвата"/"подсматривания" пароля (ключа) в момент его ввода в программу Botik Key.
  • Надо знать и следовать правилам профилактики от "троянцев". В том числе: нельзя скачивать из Сети, копировать с дисков, извлекать из приложений в е-письмах подозрительные программы, и, уж конечно, нельзя запускать их.

Рекомендуемые варианты:

  • Храним "в уме", вводим с клавиатуры. Запомните пароль (парольную фразу) у себя "в уме". Нигде (ни на диске, ни на бумаге) его не записывайте. При каждом запуске Botik Key вводите пароль с клавиатуры. Следите, чтобы никто не мог подсмотреть процесс ввода пароля с клавиатуры: ни физически подсмотреть, ни виртуально. Про виртуальный перехват: помните, злоумышленник может передать Вам (под видом заманчивой программки) "троянца", который будет "подсматривать" набор Вами пароля на клавиатуре и пересылать пароль злоумышленнику по Сети.
  • Храним на съемном носителе, носитель используем кратковременно. Запишите ключ доступа в файле на съемном носителе (обычная дискета, CD-диск, FLASH/USB-диск и т.п.). Храните носитель в надежном месте. При каждом запуске Botik Key кратковременно подключайте носитель к системе (на время считывания или записи ключа доступа), после чего немедленно уберите носитель в надежное место.


Разбор угрозы: злоумышленник получил возможность работать "через" Ваш компьютер

После доступа к Вашему
компьютеру злоумышленник
может заставить
Ваш компьютер (слева)
"качать" информацию из мира
для своего компьютера (справа)

Возможные последствия

Если Вы (вольно или невольно -- рассмотрено ниже) позволили работать злоумышленнику "через" Ваш компьютер, то злоумышленник получает следующую возможность скачивать внешнюю информацию за Ваш счет:

  • злоумышленник выполняет обращение-запрос со своего компьютера на Ваш. Это локальный трафик, злоумышленнику он ничего не стоит.
  • Ваш компьютер по этому запросу обращается во внешний мир и скачивает из внешнего мира информацию, необходимую злоумышленнику. Это внешний трафик, который создает Ваш компьютер. И оплачиваете его Вы, а как же иначе? При этом никаких подмен и подлогов нет, это действительно Ваш компьютер обращался во внешний мир!
  • После этого информация из Вашего компьютера передается на компьютер злоумышленника. Это локальный трафик, злоумышленнику он ничего не стоит.

Такая схема работы может быть реализована злоумышленником:

  • за счет установки на Вашем компьютере той или иной программы типа "proxy";
  • за счет получения злоумышленником прав (telnet, ssh и подобное) удаленно выполнять работу на Вашем компьютере.

Меры противодействия при помощи программы Botik Key

Даже если злоумышленник установил у Вас возможность работы "через" Ваш компьютер (например, установил у Вас какую-то proxy-программу), Вы можете сделать Ваш компьютер "неудобным" ("непривлекательным") proxy-сервером для злоумышленника: при помощи программы Botik Key включайте доступ к внешней Сети (устанавливайте режим доступа WORLD) только на короткие периоды -- только тогда, когда это Вам нужно (а не ему! ;-). Во все остальные периоды устанавливайте любой иной режим доступа (вполне достаточно и LOCAL).

Меры профилактики

Основные направления профилактики возможности работы злоумышленника "через" Ваш компьютер:

  • Никому не надо давать никакой возможности работать на Вашем компьютере и/или писать/читать диск Вашего компьютера. Каждый, кто имел к Вашему компьютеру хоть какой-то доступ, при желании (особенно это верно для ОС Windows) мог себе установить абсолютные права на любой доступ к нему.
  • Надо помнить, что новомодные "активные" Веб-технологии, если они разрешены в Вашем Веб-браузере (Flash, скрипты в Веб-страницах и т.п.), по сути отдают разработчику страницы весьма широкий доступ к Вашему компьютеру (см. пункт выше). Например: на многих языках Веб-скриптов можно написать proxy-программу.
  • Надо знать и следовать правилам профилактики от "троянцев". В том числе: нельзя скачивать из Сети, копировать с дисков, извлекать из приложений в е-письмах подозрительные файлы и программы, и, уж конечно, нельзя запускать их.

Меры исправления ситуации

Удалите с компьютера все (установленные с Вашего ведома или установленные без спросу) средства работы "через" него и средства (настройки этих средств, "права"), позволяющие работать на нем посторонним лицам.


Различные способы хранения пароля: что выбрать?

Программа Botik::Key Pro предусматривает пять способов хранения и использования пароля (ключа) доступа:

  • "пользователь вводит пароль для построения ключа" -- при запуске программы пользователю будет предъявлено диалоговое окно ввода пароля и он введет пароль либо с клавиатуры, либо из файла;
  • "указан в переменной окружения" -- пользователь запишет ключ (построенный по паролю) в переменную окружения (environment) BOTIKKEY и в дальнейшем он будет оттуда считываться сервисом;
  • "указан в ключе реестра" -- пользователь запишет ключ (построенный по паролю) с помощью программы pw2key32.exe в ключ системного реестра, откуда он будет считываться в дальнейшем сервисом;
  • "указан в стандартном файле" -- на диске в умолчательный файл будет сохранен ключ (построенный по паролю) и в дальнейшем он будет оттуда считываться сервисом;
  • "указан в специальном файле" -- пользователь обязан задать имя файла для сохранения ключа (построенного по паролю) откуда в дальнейшем он будет считываться сервисом.

Эти способы отличаются различным удобством для Вас (насколько удобно при таком хранении ключа открывать дверь в Сеть?) и различным удобством для злоумышленника (насколько удобно ему украсть у Вас ключ).

Все как в жизни: неудобно носить связку ключей в кармане, удобнее ключ положить под коврик... но безопасно ли это?

Ради удобства пользователей мы поддержали различные варианты хранения пароля (ключа) -- в том числе и удобные, но сомнительные с точки зрения безопасности. Однако для использования мы рекомендуем только следующие варианты:

  1. Пароль храним "в уме", используем режим "пользователь вводит пароль для построения ключа", вводим с клавиатуры.
  2. Ключ храним на съемном носителе, используем режим "пользователь вводит пароль для построения ключа", носитель подключаем к компьютеру на короткое время при запуске менеджера Botik::Key Pro, при выводе диалогового окна ввода пароля считываем ключ из файла.
  3. Ключ храним на съемном носителе, используем режим "указан в специальном файле", носитель подключаем к компьютеру на короткое время при запуске компьютера, т.к. сервис запускается автоматически и во время старта будет пытаться считать ключ из файла.

Здесь "съемный носитель" -- обычная дискета, CD-диск, FLASH/USB-диск и т.п.

Обратите внимание: при использовании этих трех вариантов Вам надо помнить и использовать на практике то, что записано в разделе "Меры профилактики: как сберечь пароль от злоумышленника?"


Вкладка "Управление"

Основное описание интерфейса

На вкладке Управление находятся элементы управления режимом доступа и сервисом. Также, на вкладке расположены информационные панели, с помощью которых можно получить информацию о состоянии режима доступа и сервиса.

Диалоговое окно менеджера с выбранной вкладкой ''Управление''. Расположение элементов управления.
Рис. 0. Диалоговое окно менеджера с выбранной вкладкой "Управление".
Расположение элементов управления.

Вкладка "Управление" содержит следующие элементы управления:

  1. Этот графический индикатор отображает очевидным образом (светофор: "красный, желтый, зеленый с буквой 'L', зеленый") получено ли признание у Кей-сервера, допущены ли мы в Сеть. Показание этого индикатора (светофора) влияет на вид иконок в "трее".
  2. Элемент управления "Ползунок" используется для переключения режима доступа. Его можно передвигать с помощью "мыши" щелкая на необходимый уровень или перетаскивая "мышью" сам ползунок на необходимый режим. Так же если элемент управления является текущим (имеет фокус), то передвигать "ползунок" можно с помощью курсорных клавиш "вверх" и "вниз".

    Положение "ползунка" не зависит от уровня доступа который мы получили от Кей-сервера. Оно отображает затребованный нами уровень! Т.е. если возникает ситуация при которой Кей-сервер не дает нам затребованный уровень доступа, то ползунок не меняет своего положения, так как Botik::Key Pro продолжает требовать у Кей-сервера выставленный пользователем уровень доступа. Как уже было сказано выше, уровень доступа, назначенный нам Кей-сервером отображается графическим индикатором (1) и иконкой в "системном трее".
  3. Информационная панель, отображающая название выставленного в данный момент режима доступа и его краткое описание. При изменении положения "ползунка" (но когда оно еще не зафиксировано, т.е. не отпущена кнопка "мыши"), панель отображает название и описание того уровня доступа, который будет выставлен при фиксации этого положения.
  4. Кнопки запуска Кнопка запуска сервиса и останова Кнопка останова сервиса сервиса. Данные кнопки расположены здесь для удобства управления, запуск и останов сервиса также возможно осуществлять и с помощью "Панели управления сервисами" и с помощью команды "net start" (см. документацию по ОС MS Windows NT/2000/XP/2003).

    Особое удобство от использования данных кнопок могут получить пользователи ОС MS Windows 9x/ME, так как, выполняясь среде этих операционных систем, программа исполняется не как сервис, а как обычный пользовательский процесс. Так как этот процесс не имеет никаких элементов управления, соответственно нет никакой возможности останавливать его (кроме как окна со списком выполняемых в системе задач, с помощью которого можно прервать выполнение любого процесса). Кнопки управления сервисом позволяют останавливать и запускать процесс сервиса и в ОС MS Windows 9x/ME.
  5. Информационная панель, отображающая состояние сервиса. Информация на данной панели отображает не только то что сервис запущен или нет, но и то в каком состоянии находится подключение к серверу системы BotikKey.

Примеры состояния индикатора режима доступа

См. также:
Иконки области системных оповещений
Контекстное меню иконки области оповещения


Вкладка "Менеджер"

Основное описание интерфейса

На вкладке "Менеджер" находятся элементы управления настройками, отвечающие за управление окном менеджера, а так же за выставляемые менеджером режимы доступа при его запуске и выключении. На операционных системах MS Windows NT/2000/XP/2003 все эти настройки является персональными для каждого пользователя.

Диалоговое окно менеджера с выбранной вкладкой ''Менеджер''. Расположение элементов управления.
Рис. 0. Диалоговое окно менеджера с выбранной вкладкой "Менеджер".
Расположение элементов управления.

Вкладка "Менеджер" содержит следующие элементы управления:

  1. Режим загрузки менеджера предоставляет на выбор три варианта отображения окна менеджера при его запуске:
    • Нормальное окно. Это вариант, при котором окно будет отображаться на рабочем столе.
    • Свернутое окно. Если выбран этот вариант, то окно будет свернуто в панель задач.
    • Свернутое в трей окно. Выбрав этот вариант, окна не будет видно ни на рабочем столе, ни на панели задач. Оно будет спрятанным.
  2. Запускать менеджер при входе в систему. Этот элемент включает и отключает автозапуск менеджера при входе пользователя в систему.
  3. Данные элементы управления отвечают за требование определенного пользователем режима доступа при запуске и выключении менеджера.

    Вариант не изменять для случая запуска менеджера означает, что доступ будет таким, какой он есть на сервисе, на момент запуска менеджера.

    Вариант не изменять для случая выключения менеджера означает, оставить его таким, какой он есть на момент выключения менеджера вне зависимости от того, каким образом был выставлен этот режим.
  4. Различные параметры управления поведением программы:
    • Сворачивать в трей. Если выбран этот параметр, то при нажатии на кнопку [image] в заголовке окна, окно не будет сворачиваться в панель задач, в место этого окно будет прятаться в трей.
    • Сворачивать в трей при закрытии. Если выбран этот параметр, то при нажатии на кнопку [image] в заголовке окна, процесс менеджера не будет завершать свою работу, в место этого окно будет прятаться в трей.
    • Восстанавливать по одному щелчку. Если выбран этот параметр, то окно будет восстанавливаться по одному щелчку на иконке отображаемой в трее, если не выбран, то для восстановления окна необходимо щелкнуть дважды.
    • Звуковой сигнал при экстренном событии. Сервисная часть программы информирует менеджера о происходящих событиях. Если выбрать этот параметр, то менеджер будет подавать звуковой сигнал для некоторых типов событий (ошибка и сообщение от провайдера). Звуковые файлы (error.wav и message.wav), проигрываемые программой для этих событий, находятся в директории где установлена программа.

      При возникновении подряд идущих событий типа "ошибка", звуковой сигнал подается только один раз.
    • Форсировать отображение журнала событий. Если выбран этот параметр, то при возникновении экстренных событий (ошибки и сообщения от провайдера) менеджер будет отображать окно Журнала событий.
    • Количество событий отображаемых в журнале. Здесь можно указать максимальное количество строк отображаемых Журналом событий содержащих сообщения о событиях. При достижении указанного значения, Журнал событий будет удалять самое старое событие. Если установить это значение в 0 (ноль), то ограничение на максимальное количество будет отменено.

      Данная опция позволяет сократить расход оперативной памяти компьютера на хранение огромного количества потерявших актуальность событий.

У программы-менеджера нет обычного рабочего окна, есть только диалоговое окно настроек, о котором и идет речь. Стандартным поведением диалогового окна является его исчезновение (для нашего диалогового окна настроек менеджера, мы будем говорить, что оно сворачивается (прячется) в трей) при нажатии на кнопки [image] и [image]. При нажатии на кнопку [image] окно остается на рабочем столе, а внесенные изменения в настройки сохраняются.

Примеры интерфейса

См. также:
Иконки состояния в "трее"
Журнал событий


Вкладка "Сервис"

Основное описание интерфейса

На вкладке "Сервис" находятся элементы управления настройками сервиса.

Диалоговое окно менеджера с выбранной вкладкой ''Сервис''. Расположение элементов управления.
Рис. 0. Диалоговое окно менеджера с выбранной вкладкой "Сервис".
Расположение элементов управления.

Вкладка "Сервис" содержит следующие элементы управления:

  1. Определение адреса (имени) машины, на которой установлен BotikKey сервер. В сети СТ "Ботик" BotikKey сервер установлен на всех шлюзах (gateway) локальных сетей. Поэтому достаточно поставить галочку.

    Существует одно исключение, касающееся операционных систем MS Windows 95. В этих операционных системах программа не поддерживает автоматического определения адреса используемого шлюза (gateway). Таким образом, опция BotikKey сервер установлен на шлюзе не работает в этих операционных системах. Для того чтобы указать, где установлен сервер, Вам необходимо вручную ввести его адрес в поле Адрес BotikKey сервера. Адрес шлюза можно посмотреть в конфигурации сетевой карты которая подключена к сети СТ "Ботик".

    В следующих версиях я постараюсь добавить поддержку автоматического определения шлюза и в эти операционные системы.
  2. С помощью этого параметра можно переопределять номер порта, на котором "слушает" сервер. Стандартный номер порта для BotikKey сервера -- 12040.
  3. Селектбокс позволяет задать уровень доступа, который сервис будет требовать у сервера при запуске.

    Вариант "не изменять" означает требовать уровень доступа такой, какой он был на момент выключения сервиса (например, из-за перезагрузки системы).
  4. Параметры управления обработкой событий:
    • Записывать происходящие события в лог-файл. Если выбран этот параметр, то все происходящие события сервис записывает в лог-файл. Имена лог-файлов систематизируются по дате, и имеют следующий вид: ГГГГ-ММ-ДД.log. Лог-файлы сохранаются в директори logfiles находящейся в директории, где установленна программа Botik::Key Pro.
    • Оповещять менеджер о происходящих событиях. Если выбран этот параметр, то сервис оповещает менеджер о происходящих событиях. Это необходимо для того, чтобы Журнал событий, находясь в режиме синхронизации с сервисом, мог получать от него сообщения о происходящих событиях и отображать эти события. Подробнее о том как устроена система оповещения рассказывается в разделе Журнал событий.

Изменения параметров настроек сервиса вступают в силу сразу же, без перезагрузки сервиса.

См. также:
Вкладка "Ключ доступа"
Журнал событий


Вкладка "Ключ доступа"

Основное описание интерфейса

На вкладке "Ключ доступа" находятся элементы управления настройками, относящимися к ключам доступа.

Диалоговое окно менеджера с выбранной вкладкой ''Ключ доступа''. Расположение элементов управления.
Рис. 0. Диалоговое окно менеджера с выбранной вкладкой "Ключ доступа".
Расположение элементов управления.

Вкладка "Сервис" содержит следующие элементы управления:

  1. Кнопка Создать ключ доступа запускает утилиту для построения (шифрования) ключей доступа используя парольную фразу.
  2. Кнопка Установить ключ доступа открывает диалоговое окно для ввода пароля или ключа доступа пользователем.

    С помощью этого диалогового окна пользователь может заменить ключ доступа, используемый сервисом в данное время. Даже если сервис сконфигурирован так, чтобы использовать хранящийся на машине ключ доступа, пользователь может заменить его на другой. Это так называемый сессионный ключ доступа, так как он не заменяет собой тот ключ доступа, который хранится на машине и после перезагрузки сервиса будет забыт.

    Данная возможность может использоваться, например, если ключ доступа, хранящийся на машине и использующийся сервисом в данный момент, обладает правом требовать максимальный доступ LOCAL, с помощью этого диалога, мы можем заменить его на другой ключ с большим приоритетом.

    Это диалоговое окно используется и в том случае, если сервис сконфигурирован так, что пользователь сам вводит пароль (ключ доступа).

    Так же стоит упомянуть, что менеджер выводит на экран это диалоговое окно всякий раз, когда сервис не имеет ключа доступа. Это может произойти, например, тогда, когда вы настроили сервис читать ключ доступа из переменной окружения, но забыли создать такую переменную, или она пуста, или запись, хранящаяся в ней, не является правильным ключом доступа.
  3. Элементы управления указывающие, откуда сервис должен считывать ключ доступа.

Изменения параметров настроек ключа доступа вступают в силу сразу же, без перезагрузки сервиса.

См. также:
Вкладка "Сервис"


Журнал событий

В журнале событий отражаются события взаимодействия программы с Кей-сервером. Все события можно сохранять в файл (см. Вкладка Сервис).

Окно журнала событий

Для просмотра событий из файла, так и для отображения их в реальном времени служит Окно журнала событий (см. Рис. 0).

Общий вид окна журнала событий
Рис. 0. Общий вид окна журнала событий.

Существует четыре типа событий:

  • -- событие сообщающее о произошедшей ошибке;
  • -- событие информирующее о каком-либо действие;
  • -- событие подтверждающее успешное выполнение какого-либо действия;
  • -- событие содержащее текст сообщения переданное провайдером;

Панель инструментальных кнопок

Панель инструментальных кнопок
Рис. 1. Панель инструментальных кнопок.

  • Кнопка "Сохранить в файл" -- сохраняет содержимое окна в лог-файл;
  • Кнопка "Открыть из файла" -- отображает содержимое лог-файла в окне просмотра (при открытии файла синхронизация с сервисом приостанавливается и содержимое окно очищается);
  • Кнопка "Синхронизировать данные с сервисом" -- включает синхронизацию отображения событий с сервисом (если в окне был отображен лог-файл, то содержимое окна очищается);
  • Кнопка "Очистить окно просмотра" -- очистить окно просмотра сообщений;
  • Кнопка "Копировать выделенное в буфер обмена" -- скопирует выделенные строки с событиями в буфер обмена;
  • Кнопка "Автопрокрутка списка сообщений в конец" -- включает и отключает автопрокрутку списка сообщений к последнему добавленному сообщению в список.

См. также:
Вкладка "Менеджер"
Вкладка "Сервис"


Иконки области системных оповещений

Основное описание интерфейса

Область системных оповещений (в народе просто "системный трей" или просто "трей") расположена в правой части панели задач, если панель расположена внизу или вверху экрана или в нижней части этой панели, если она расположена слева или справа.

Изображение иконки в "трее" позволяет визуально контролировать состояние сервиса при закрытом диалоговом окне менеджера. Дополнительным свойством является следующее:

  • Открытие диалогового окна менеджера по щелчку или двойному щелчку левой кнопкой "мыши" по иконке.
  • Открытие диалогового окна ввода пароля или ключа доступа осуществляется щелчком по иконке средней кнопкой "мыши".
  • Щелкнув правой кнопкой "мыши" по иконке, вы получите контекстное меню иконки.

Изображение иконки зависит от статуса, в котором находится сервис. Ниже приведены все возможные изображения и их описания:

  • -- это изображение соответствует погашенному светофору на вкладке Управление. Условием появления такой иконки служит отсутствие связи менеджера с сервисом. Это может происходить по нескольким причинам, например, не загружен (не запускали вообще или выключили) процесс сервиса или произошла какая-нибудь ошибка, и процесс сервиса был выгружен из памяти операционной системой.

    Если Вы только что запустили машину, то операционная система могла еще не успеть запустить процесс сервиса. Подобную ситуацию можно наблюдать на ОС MS Windows 9x/ME, так как в этих операционных системах, процессы сервиса и менеджера запускаются в одно и тоже время (если используется автозагрузка). В операционных системах MS Windows NT/2000/XP/2003 сервисы с автозапуском начинают запускаться системой до момента входа пользователя в систему и обычно такая ситуация не наблюдается, но бывают исключения.
  • -- это изображение соответствует горящему желтому свету светофора на вкладке Управление. Иконка отображается в те моменты работы системы, когда нет ясного (подтвержденого) уровня доступа. Например, в момент, когда сервис осуществляет переключение режимов доступа или когда сервис пытается подключиться к Key-серверу.
  • -- это изображение соответствует горящему красному свету светофора на вкладке Управление. Иконка отображается, когда установлен уровень доступа NONE.
  • -- это изображение соответствует горящему зеленому свету светофора с буквой L на вкладке Управление. Иконка отображается когда установлен уровень доступа LOCAL.
  • -- это изображение соответствует горящему зеленому свету светофора на вкладке Управление. Иконка отображается, когда установлен уровень доступа WORLD.

См. также:
Вкладка "Управление"
Контекстное меню иконки области оповещения
Ключевые слова и термины: Режим доступа (регион доступа)
Ключевые слова и термины: Системный журнал событий


Контекстное меню иконки области оповещения

Основное описание интерфейса

Контекстное меню предоставляет доступ к диалоговому окну менеджера, возможности изменять уровень доступа, не открывая диалогового окна и еще некоторую функциональность.

Корневое меню

Когда Вы щелкаете правой кнопкой "мыши" по иконке в области оповещения, то появляется контекстное меню изображенное на Рис. 0.

Контекстное меню.
Рис. 0. Контекстное меню иконки. Корневое меню.

Это контекстное меню содержит следующие элементы:

  • Настройки. Выбрав этот элемент меню, на дисплее отобразится диалоговое окно менеджера.
  • Задать пароль доступа. Этот пункт меню отвечает за отображение диалогового окна запроса пароля или ключа доступа.
  • Утилита преобразования пароля. Запустит программу преобразования парольной фразы в ключ доступа (pw2key32.exe).
  • Открыть журнал событий. Отобразит окно Журнала событий.
  • Режим доступа к сети. Открывает подменю, с помощью которого можно переключать режимы доступа к сети (Рис. 2).
  • Справка. Открывает подменю со справочной информацией (Рис. 1).
  • Выход. Завершает работу менеджера, но сервис продолжает работать с выставленными параметрами.
  • Выход и выключение сервиса. Завершает работу менеджера и сервиса. Выбрав этот пункт, доступ к сети прекратится автоматически через несколько секунд после того, как сервис прекратит свою работу.

Подменю "Справка"

Доступ к этому подменю осуществляется выбором пункта Справка в корневом меню. Это меню содержит различную справочную информацию относящуюся к программе.

Контекстное меню.
Рис. 1. Контекстное меню иконки. Подменю "Справка".

Это контекстное меню содержит следующие элементы:

  • Помощь. Этот пункт предоставляет доступ к документации.
  • GNU General Public License. Открывает диалоговое окно, содержащее текст лицензии под которой распространяется Botik::Key Pro.
  • Web-сайт программы. В браузере открывается сайт программы.
  • О программе. Открывает диалоговое окно с краткой информацией о программе (название, полный номер версии и прочее).

Подменю "Режим доступа к сети"

Доступ к этому подменю осуществляется выбором пункта Режим доступа к сети в корневом меню. Это меню содержит опции для переключения режима доступа к сети.

Контекстное меню.
Рис. 2. Контекстное меню иконки. Подменю "Режим доступа к сети".

  • Выключено (NONE). Установить режим доступа NONE.
  • Только локальная (LOCAL). Установить режим доступа LOCAL.
  • Полный доступ (WORLD). Установить режим доступа WORLD.

См. также:
Вкладка "Управление"
Ключевые слова и термины: Режим доступа (регион доступа)
Иконки области системных оповещений
Журнал событий


Диалоговое окно ввода пароля/ключа доступа

Диалоговое окно ввода предназначено для тех случаев, когда пользователь настраивает программу так, что он сам будет вводить пароль (или ключ) доступа. Изображение этого окна представлено ниже, на рис. 0.

Диалоговое окно ввода пароля (ключа) доступа.
Рис. 0. Диалоговое окно ввода пароля (ключа) доступа.

Поле ввода, расположенное на диалоговом окне, предназначено для ввода парольной фразы самим пользователем с клавиатуры. После того, как пользователь нажимает кнопку [image], менеджер создаст из этой фразы ключ доступа и передаст его сервису.

Отображение парольной фразы в поле ввода можно отменить, поставив метку в "Отображать пароль звездочками". Данная опция полезна, если Вам предстоит вводить пароль при присутствии посторонних лиц.

Так же, диалог ввода пароля (ключа) доступа предоставляет пользователю возможность использовать уже готовые ключи доступа, хранящиеся на носителях информации. Это подробно описано в статьях "Разбор угрозы: кража пароля (ключа) доступа к Сети" и "Различные способы хранения пароля: что выбрать?".

Для того чтобы использовать готовый ключ доступа, хранящийся в файле, необходимо нажав на кнопку [image] выбрать файл, используя открывшееся диалоговое окно выбора файла (Рис. 1) в котором хранится уже готовый ключ доступа. После того как файл выбран, необходимо просто нажать кнопку [image] на диалоговом окне ввода пароля (ключа) доступа. Менеджер просто передаст прочитанный из файла ключ доступа сервису.

Диалоговое окно выбора файла.
Рис. 1. Диалоговое окно выбора файла.

Диалоговое окно ввода пароля так же отображается в тех случаях, когда сервису не удалось получить ключ доступа из указанного места хранения. Это может произойти в том случае, если Вы указали, например, что ключ хранится в переменной окружения, но не записали его в переменную. Подобные ситуации могут происходить и тогда, когда Вы указываете, что ключ хранится в файле или реестре, не записав его туда.

Прочитанный ключ, сервис проверяет на правильность (количество цифр и диапазон цифр). Если прочитанный пароль не удовлетворяет правильному формату, то сервис, как и в предыдущем случае, так же выдает запрос на ввод пароля (ключа) пользователем.

См. также:
Пароль доступа и ключ доступа
Ликбез по информационной безопасности
Разбор угрозы: кража пароля (ключа) доступа к Сети
Разбор угрозы: злоумышленник получил возможность работать "через" Ваш компьютер
Различные способы хранения пароля: что выбрать?


Утилита преобразования пароля в ключ доступа

Это вспомогательная программа в пакете программ Botik::Key Pro. Она позволяет перевести пароль доступа в ключ доступа (см. Пароль доступа и ключ доступа). Дополнительной возможностью программы является то, что она позволяет сохранять ключ доступа в реестре и в файлах (как в стандартном, так и в указанном пользователем). Изображение окна программы представлено ниже, на рис. 0. Доступ к программе можно получить из диалогового окна менеджера на вкладке Ключ доступа, из контекстного меню и просто запустив программу pw2key32.exe.

Окно утилиты преобразования.
Рис. 0. Окно утилиты преобразования.

Как видно из рисунка, интерфейс пользователя программы довольно прост. Единственное, о чем необходимо упомянуть, так это то, что при помощи этой утилиты можно не только сохранять вновь созданный ключ доступа, но и ключи доступа, которые были созданы ранее и записаны в файл. Для этого необходимо, нажав на кнопку [image], выбрать файл, используя открывшееся диалоговое окно выбора файла (Рис. 1) в котором хранится уже готовый ключ доступа. После того, как файл выбран, в поле под номером [image] отобразится прочитанный ключ доступа (при условии, что нет отметки в "Не отображать шифрованный ключ в поле"). Дальше Вам остается только сохранить ключ доступа в необходимом месте.

Диалоговое окно выбора файла.
Рис. 1. Диалоговое окно выбора файла.

У программы нет возможности сохранять ключ доступа в переменную окружения, это делается самим пользователем. Для этого необходимо скопировать ключ доступа из поля [image] в буфер обмена. И, в зависимости от версии ОС, выполнить следующее:

  • Windows 9x/ME --
  • Windows NT/2000/XP/2003 -- Используя диалоговое окно системных настроек, создать, если еще не создана, глобальную переменную окружения с именем BOTIKKEY и в качестве ее значения указать ключ доступа. Это делается следующим образом:
    1. Открываем диалоговое окно системных настроек:
      Старт(Start)->
      Панель управления(Control Panel)->
      Система(System)
    2. Выбираем вкладку Дополнительное(Advanced)
    3. Нажимаем на кнопку Переменные окружения(Environment Variables)
    4. В список Системные переменные(System Variables) добавляем новую переменную либо, если переменная BOTIKKEY создана, изменяем ее значение. Добавлять переменную необходимо именно в список системных переменных, а не в список пользовательских переменных, который расположен в этом же окне, но чуть выше. Список переменных пользователя недоступен сервису.

В следующих версиях программы собираюсь добавить возможность сохранения ключа доступа и в переменную окружения.

См. также:
Пароль доступа и ключ доступа
Ликбез по информационной безопасности
Разбор угрозы: кража пароля (ключа) доступа к Сети
Разбор угрозы: злоумышленник получил возможность работать "через" Ваш компьютер
Различные способы хранения пароля: что выбрать?


Первый запуск

Если установлен брандмауэр (firewall)...

Если у Вас установлен брандмауэр, то необходимо добавить перечисленные ниже опции в правила.

Менеджеру (bkpmgr32.exe) необходимо разрешить доступ к 80 порту (HTTP). С помощью HTTP протокола, менеджер осуществляет проверку наличия новых версий на сайте программы. Для функционирования программы в целом, данное требование не является необходимым.

Сервису (bkpsvc32.exe) необходимо разрешить доступ к порту 12040 (это является стандартным портом BotikKey-сервера, если в вашей сети номер порта другой, то используйте его). Это является обязательным требованием для функционирования. Доступ можно открывать только к компьютеру, на котором установлен BotikKey-сервер, обычно, это шлюз (gateway) в вашей сети.

Первые шаги...

При первом запуске, после установки Botik::Key Pro (если Botik::Key Pro не был установлен на машине ранее, иначе же поведение программы будет зависеть от тех настроек которые были ранее), на экран выводится диалоговое окно ввода пароля (ключа) доступа. Дальнейшие действия могут быть следующими:

  • ввести пароль доступа в поле ввода с клавиатуры либо прочитать ключ доступа из файла (подробнее см. "Диалоговое окно ввода пароля/ключа доступа");
  • нажать кнопку Отмена и перейти на вкладку "Ключ доступа" диалогового окна менеджера для того, чтобы произвести необходимые настройки.

См. также:
Диалоговое окно ввода пароля/ключа доступа
Вкладка "Ключ доступа"


Пароль доступа и ключ доступа

Пароль доступа

Пароль, обычно, придумывают такой, чтобы он был длинным, сложным, но легко запоминался пользователем. С этой точки зрения особенно хороши пароли-фразы, с заглавными и строчными буквами, с пробелами, цифрами и знаками препинания. Например, легко запомнить такую достаточно длинную пароль-фразу (запомнить со всеми пробелами и знаками препинания):

All you need is love!..

И подготовленный пользователь может достаточно ловко ее вводить на клавиатуре...

Примечание: такой пароль взят для примера. Это не очень удачный пароль: он является прямой цитатой из популярной песни и поэтому неустойчив к подбору при помощи так называемой словарной атаки.

Обратите внимание, пароли доступа Абоненты устанавливают (изменяют) самостоятельно на странице: http://nadmin.botik.ru/.

Ключ доступа

Ключ -- это некоторая строка символов, которая специальным образом строится из пароля. Например, ключ, построенный из пароля-фразы "All you need is love!.." получается вот таким:

6be1ec3b06d6bfa9a4580226a0a8405b

По некоторым причинам в файле удобнее хранить не пароль, а ключ доступа.

Среди прочего это еще и мудро: представим себе, что злоумышленник получил шанс взглянуть на ключ доступа (именно взглянуть: без возможности записать на бумажке или в файле)... вряд ли он запомнит в уме строчку "6be1ec3b06d6bfa9a4580226a0a8405b".

Пароли (и пароли-фразы) -- предназначены для запоминания людьми, а ключи (построенные от паролей) -- для хранения в файлах.

Равноправность пароля и ключа, построенного от пароля

Программе Botik::Key Pro можно:

  • либо с клавиатуры ввести правильный пароль;
  • либо предоставить программе Botik::Key Pro файл с ключом доступа, построенном от правильного пароля, либо задать этот ключ в переменной BOTIKKEY среды (environment).

В обоих случаях программа Botik::Key Pro с одинаковым успехом будет строить ответы на запросы Кей-сервера.

То же самое с точки зрения информационной безопасности: злоумышленнику достаточно:

  • либо украсть пароль -- подглядеть (реально или виртуально), какой пароль (пароль-фразу) Вы вводите;
  • либо "украсть" файл с ключом доступа.

Как по паролю построить ключ доступа

Если Вы желаете заранее перевести пароль доступа в ключ доступа (например, чтобы заранее записать его в некоторый файл), то самый простой и прямой путь -- воспользоваться специальной программой pw2key32.exe, входящей в пакет поставки Botik::Key Pro. Программа организована как единственное окно, которое содержит все необходимое, чтобы воспользоваться данной программой (включая достаточное описание использования программы).

См. также:
Утилита преобразования пароля в ключ доступа


F.A.Q. или ЧаВО: Программа не запущена, а доступ к сети есть

Botik::Key Pro: F.A.Q. или ЧаВО

Программа не запущена, а доступ к сети есть. В чем проблема?

Q: У меня стоит Botik::Key Pro вернее он не постоянно запущен. Последние дней 5 или 6 я его могу не запускать совсем и свободно работать в локальной сети. На nadmin.botik.ru у меня установлено 2 пароля на world и local. Почему так получилось, что я без пароля могу входить в местную сеть? Где-то, что-то не так работает?

A: Нет, все работает так как и должно. Функциональная часть программы Botik::Key Pro состоит из двух частей: менеджер управления и сервисное приложение. Менеджер управления -- это приложение, имеющее диалоговое окно и органы управления (графический интерфейс пользователя (GUI)). Оно используется только для управления сервисным приложением Botik::Key Pro. Сервисное приложение -- это приложение, не имеющее графического интерфейса пользователя (GUI) и выполняющее некоторую задачу. В данном случае, оно выполняет всю необходимую работу по обеспечению доступа к сети. Для того чтобы управлять и настраивать это приложение, необходимо использовать Менеджер управления. Если сервисное приложение выполняется под управлением ОС Windows NT/2000/XP/2003, то оно запускается операционной системой во время загрузки компьютера, т.е. до того как пользователь зарегистрируется в системе.

Скорее всего у Вас в настройках сервиса выставлен режим "изменить на локальный (LOCAL)" при запуске сервиса. Таким образом, так как сервис запускается самой ОС при загрузке компьютера, а менеджер управления не занимается ничем кроме того как управлять сервисом, у вас имеется (зависит от настроек сервиса) доступ к сети даже тогда, когда менеджер не запущен.

См. также:
Подробнее о Botik::Key Pro
Настройки сервиса (Вкладка "Сервис")


F.A.Q. или ЧаВО: Программа не запущена, а доступ к сети есть

Botik::Key Pro: F.A.Q. или ЧаВО

Почему после перезагрузки компьютера программа опять запрашивает пароль доступа?

Q: После установки и запуска Botik::Key Pro, программа запросила ввести пароль доступа к сети с помощью диалогового окна. Я ввел пароль. Все хорошо работало, но после перезагрузки компьютера программа опять запрашивает пароль доступа к сети. Что я делаю не так?

A: Дело в том, что, вводя пароль/ключ доступа с помощью предлагаемого программой диалогового окна, вы указываете сервису так называемый сессионный ключ доступа, который программа будет использовать до перезагрузки компьютера, либо пока его не изменят с помощью этого же диалогового окна.

Для того, чтобы программа всегда знала некоторый ключ, необходимо его записать в определенное в настройках место. Это можно сделать с помощью утилиты преобразования пароля в ключ доступа.

См. также:
Диалоговое окно ввода пароля/ключа доступа
Вкладка "Ключ доступа"
Утилита преобразования пароля в ключ доступа


Ключевые слова и термины

  • Менеджер сервисных приложений (Service Control Manager (SCM)). Системная служба в операционных системах MS Windows NT/2000/XP/2003 с помощью которой производится управление системными сервисными приложениями. Он запускается во время загрузки операционной системы, и осуществляет автоматический запуск сервисов.
  • Системные сервисные приложения (сервисы). Системные приложения использующиеся для реализации некоторых компонентов операционной системы, например, таких как Web, Ftp-серверов, очередей печати, служб удаленного доступа, антивирусных приложений и прочих системных компонентов.
    Сервисы могут быть настроены для запуска в момент загрузки системы, могут загружаться по требованию пользователя с помощью панели управления сервисами или по требованию других приложений. Сервисы могут выполняться даже если ни один из пользователей не вошел в операционную систему.
  • Системный журнал событий. Это подсистема операционных систем MS Windows NT/2000/XP/2003 в которую могут записываться события, происходящие в системе. Просмотреть журнал событий можно запустив программу Event Log Viewer из меню (Start->Control Panel->Administrative Tools).
  • Запрос (challenge). Кей-сервер присылает программе Botik::Key Pro запрос ("загадку"), на который от имени Абонента можно правильно ответить, если знаешь пароль (ключ) доступа данного Абонента к Сети.
  • Ответ (response). По полученному запросу ("загадке") и по полученному от пользователя паролю (ключу) доступа (он известен только пользователю) программа Botik::Key Pro строит ответ ("разгадку") и передает ее Кей-серверу. Используются принципы "знаешь правильный пароль -- построишь правильный ответ и тем самым подтвердишь, что именно ты и есть тот самый Абонент".
  • Признанные и отверженные. Если на свой запрос Кей-сервер получает правильный ответ (то есть, ответ соответствует паролю пользователя), то Кей-сервер признает, что с ним общается именно "тот самый Абонент". Иначе Кей-сервер отвергает попытку выдать себя за "того самого" Абонента.
  • Пропуск в Сеть. В случае признания Кей-сервером ответа, пользователь получает право пользования Сетью (конечно, при наличии неизрасходованной предоплаты на лицевом счету Абонента), в случае непризнания -- не получает такого права.
  • Нейтральные информационные сообщения. Кроме запросов (challenge) от Кей-сервера могут исходить и обычные информационные сообщения (например, о том, что средства на лицевом счету Абонента подходят к концу, или еще что-то). Эти информационные сообщения программой Botik::Key Pro доставляются пользователю для прочтения.
  • Пароль и ключ доступа. Пароль обычно придумывают такой, чтобы он был длинным, но легко запоминался пользователем. А для хранения на диске в файле удобнее хранить не пароль, а построенную по паролю некоторую строку символов -- ключ. Программе Botik Key достаточно либо задать пароль, либо предоставить файл с ключом доступа -- в обоих случаях она с одинаковым успехом будет строить ответы на запросы Кей-сервера. Подробнее см. раздел "Пароль доступа и ключ доступа".
  • Режим доступа (регион доступа) в запросе на доступ к Сети. При помощи программы Botik::Key Pro можно запросить у Кей-сервера различный режим (регион) доступа для своего компьютера:
    • WORLD -- "разреши для данного компьютера и внутренние (внутри СТ "Ботик"), и внешние обмены";
    • LOCAL -- "разреши для данного компьютера только внутренние (внутри СТ "Ботик") обмены, запрети внешние обмены";
    • NONE -- "запрети для данного компьютера все обмены: и внутренние (внутри СТ "Ботик"), и внешние".
  • WORLD-ключ, LOCAL-ключ, NONE-ключ: режим доступа (регион доступа) у пароля (ключа) доступа. Абонент может иметь несколько паролей (ключей) доступа; у каждого пароля (ключа) определяется свой предельный режим (регион) доступа: WORLD, LOCAL или NONE.
    • WORLD-ключ: имея пароль (ключ) с предельным режимом WORLD, можно успешно запросить у Кей-сервера любой доступ (WORLD, LOCAL или NONE).
    • LOCAL-ключ: имея пароль (ключ) с предельным режимом LOCAL, можно успешно запросить у Кей-сервера только доступ LOCAL или NONE, доступ WORLD получить не удастся: если при помощи LOCAL-ключа будет запрошен доступ WORLD, то Кей-сервер предоставит доступ LOCAL.
    • NONE-ключ: имея пароль (ключ) с предельным режимом NONE, можно успешно запросить у Кей-сервера только доступ NONE, доступ WORLD или LOCAL получить не удастся: если при помощи LOCAL-ключа будет запрошен доступ WORLD или LOCAL, то Кей-сервер предоставит доступ NONE.
    Иметь несколько паролей (ключей) доступа удобно. Пример использования: WORLD-ключ имеет только глава семьи (или учитель в школе) и никому его не отдает его. LOCAL-ключи даются остальным членам семьи (ученикам), после чего можно быть спокойным, что им доступны все городские сетевые ресурсы, не доступны внешние обмены и, поэтому, они не могут ввести семью (школу) в расход при помощи внешних обменов. А если владелец LOCAL-ключ провинился, то глава семьи может на время (до искупления вины) ограничить режим доступа у данного ключа уровнем NONE.